AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Blunpab

Climate Control Fix

4 posts in this topic

Hi all I don't usually do the forum thing but thought I d let you know a quick fix for the lack of heat that was coming out on my 09 mk7 fiesta titanium tdci.

For a number of months the climate control would not kick out any hot air, even on full blast maximum heat. Some times when you reved it hard it would come through but 9 out of 10 times just ice cold air.

Thought it might be the water pump but all fine there, heater control vavle? They don't have em on the mk7.

Just when I was thinking bugger this might need a dealer, I checked the pollen filter and it was black as the night! I changed it and now it' seems to be working fine fingers crossed.

Who would have thought it after wks of worry and scanning the net.

Hope this helps someone

Cheers

post-46661-0-03697900-1378741185_thumb.j

Share this post


Link to post
Share on other sites
 

If it works on a fiesta, it could work else where.

Share this post


Link to post
Share on other sites

The pollen filter should have been replaced at one of the scheduled services for an '09 reg car.

As far as I can remember this was changed at the 2nd or 3rd service on my old '59 reg Fiesta. I can't check the service paperwork as this was all handed over when I traded it in.

Did your car come with FSH?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now