• Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Get Your Club gear
      Get Your Club gear
    • Join Premium & Save
      Join Premium & Save
    • Share Your Car Experience
      Share Your Car Experience

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Endura De Fuel Pump Issues

1 post in this topic


A slightly different problem from the norm possibly coming up :huh: I have a endure de engine with the lucas fuel pump fitted. The problem I have is it was fitted in my boat but removed for repairs, I have now re-fitted the engine but couldn't get it to run unless using easy start and only for a second or so. After further inspection I found that there is a multi plug with 3 pins connected to the fuel pump. I guess one wire is for the fuel stop soleoid one earth and not sure on the other?? So the problem as I don't have the whole wiring harness is there any way if knowing which pin relates to what?

Thank for any advice in advance..

Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now