Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


jamwatn

New Member! New Problems!

4 posts in this topic

Hi!

I'm a new member as I just bought a 2007 fiesta!

Sadly the car has a minor problem with the screen wash.

It doesn't work and after a quick Google this seems to be fairly common.

The motor doesn't run nor do I get any voltage across the feed to the motor

The wipers work fine.

Any ideas folks?

Checked fuse as standard but there only seems to be a fuse for the wipers.

Thanks in advance!

Share this post


Link to post
Share on other sites
 

when you flick the switch, do you hear a buzz noise?

Share this post


Link to post
Share on other sites

No noise at all..silence!

Share this post


Link to post
Share on other sites

Sounds like a faulty switch.

You would need to replace the stalk that controls window wiper and screen movements.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now