• 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Get Your Club gear
      Get Your Club gear
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Share Your Car Experience
      Share Your Car Experience
    • Join Premium & Save
      Join Premium & Save


wijcc

Ford Focus Stereo Problem

5 posts in this topic

Hi all,

I seem to be having problems with the stereo in my car. It is a ford
6000 CD stereo unit. I can play CDS on the unit fine.. but suddenly it
won't pick up any radio stations anymore.. also my preset buttoned
stations will not work, tries to search for stations when i press the
button(s).

I have tried using another aerial from another focus, but it made not
difference, infact it made no difference with or without a aerial.

The only other thing i can think of other than the fault being in the
stereo unit itself is the wiring going upto the aerial on the roof of
the car.

Is it possible for the radio fuction on stereo to malfunction?? What
other things can i check without having to buy another stereo for the
car?

Thanks in advance guys.

Share this post


Link to post
Share on other sites
 

The Focus Guides section is intended to be used to post guides, and tutorials, but not to answer questions. as such I will move your question somewhere more appropriate.

It does sound like you have lost the aerial connection, I would say your best bet is to check over the connections and ensure that the aerial connection haunt separated from the rear of the stereo.

Share this post


Link to post
Share on other sites

Thank you for moving it to the correct forum.

It is strange... but from a cold start it seems to work okay.. but after driving for a while the reception goes. However i have found that if I remove the removal facia part and the blow and shake it for a bit and then put i back on it seems to start working for a while longer (gets radio reception).

Playing a CD works flawlessly continiously.. so it seems quite strange to me.. any ideas anyone?

Share this post


Link to post
Share on other sites

Sounds like a loose connection somewhere in the radio itself.

A dealer will charge big money for repairs and many hundreds for a replacement.

Best option may be to get one via eBay.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now