Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


womble68

Fault?

5 posts in this topic

anyone help this morning went out to car put key in to start warning beep and display said engine malfunction and power steering malfunction switched of tried again same thing turned of locked car then unlocked and car started fine, half mile down road beeping started and display said engine malfunction + power steering malfunction all lights on dash lit up, turn car of and back on started fine drove to work and home again about 15 miles been out and about again and everything is fine any ideas on this or do you think it was just a gremlin in the car lol cheers for any advice

Share this post


Link to post
Share on other sites
 

anyone help this morning went out to car put key in to start warning beep and display said engine malfunction and power steering malfunction switched of tried again same thing turned of locked car then unlocked and car started fine, half mile down road beeping started and display said engine malfunction + power steering malfunction all lights on dash lit up, turn car of and back on started fine drove to work and home again about 15 miles been out and about again and everything is fine any ideas on this or do you think it was just a gremlin in the car lol cheers for any advice

Seems like an odd one as it's all working correctly again now. Probably best to plug a code reader in just in case to check for any fault codes.

womble68 likes this

Share this post


Link to post
Share on other sites

If it's like the 2.0 tdci the power steering pump is hidden underneath the o/s front bumper/wing had a similar prob on my 2.0 was a corroded loose connection cleaned it up and all is ok. Worth a look

womble68 likes this

Share this post


Link to post
Share on other sites

cheers fella i'm gonna check it out tomorrow we had a lot of rain over weekend and went through a few deep puddles on the lanes round me so gonna check out connectors

Share this post


Link to post
Share on other sites

Take out the o/s headlight and you should see the pump and connectors hope you get sorted

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now