• Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Get Your Club gear
      Get Your Club gear
    • Share Your Car Experience
      Share Your Car Experience
    • Join Premium & Save
      Join Premium & Save
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


saa1

Focus Mk2 6000Cd Stereo Problem

4 posts in this topic

Hi was wondering if anyone can help? My stereo has stopped working all together no display or sound the only thing working is my parrot ck3100 though i take it the parrot only uses the speakers for sound. Is there a quick fix or is it a case of buying a new unit?

Share this post


Link to post
Share on other sites
 

have you tried the fuse

Share this post


Link to post
Share on other sites

+1 on the fuse.

If you're unsure of which one it is there's a fusebox layout guide in my links below this message

Yes the Parrot CK3100 just patches into the speaker loom and mute wire to the radio connector so will work even if no radio is present

Share this post


Link to post
Share on other sites

I have tried the fuse with a new one but the old one was fine as i put it through a multi meter.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now