Jump to content


Show
Photo

engine wont idle


  • Please log in to reply
2 replies to this topic

#1 psmk2

psmk2

    Member

  • New Member
  • PipPip
  • 11 posts
  • Ford Model: escort
  • Location:

Posted 11 April 2009 - 10:32 PM

hi,

i have a mk2 escort 1.6 ghia and for some reason it wont idle without a bit choke . the engine runs sweet on the run but as soon as i stop it cuts out, i have just replaced the cylinder head but i had this problem before i started the job? even if i let it idle with a bit choke it runs great but as soon as i push the choke in the car stalls any ideas what it could be?

peter

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,463 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 12 April 2009 - 01:30 PM

it sounds like a problem with the mixture or the slow idle settings.

#3 sr-performance

sr-performance

    Feet Under The Table

  • New Member
  • PipPipPipPip
  • 147 posts
  • Ford Model: Ford Escort Van TDDI
  • Year: 2014
  • Location:

Posted 14 April 2009 - 06:14 PM

Hi pete,
clean idle jets in top of carb they used to be prone to picking up a bit of muck and blocking hence wont idle.. easy to do though..



steve



www.sr-performance.co.uk


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users