Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


jamesm182

Ford Oc App Ios Now Out (Based On Tapatalk) Update!! Now Out On Ios And Android

74 posts in this topic

good tip there in case anyone else needs it :D

Share this post


Link to post
Share on other sites
 

Hi guys

I seem to be having problems with the app on my Galaxy S4

App was working fine until I updated the phone the the app hangs on the blue start screen.

Any ideas?

Share this post


Link to post
Share on other sites

what update did you do and have you tried a fresh install?

sent using the Ford OC app for android.

Share this post


Link to post
Share on other sites

Hi i had the same problem. On my s4 it was due to the version of kasperky i had. I uninstalled and replaced with an older version and that sorted it. Dont know of that helps?

Sent from my GT-I9505 using Ford OC mobile app

Share this post


Link to post
Share on other sites

Working now chaps :) removed my antivirus and all is OK

Share this post


Link to post
Share on other sites

Cool.

Sent from my GT-I9505 using Ford OC mobile app

Share this post


Link to post
Share on other sites

What AV did you have? was that Kaspersky?

Share this post


Link to post
Share on other sites

Avast.

Also may be to do with an Android 4.3 update as some of my apps stopped working.

Share this post


Link to post
Share on other sites

New update driving me mad. Constantly loading.

Can email notifications be turned off within the app?

Sent from my GT-I9300 using Ford OC mobile app

Share this post


Link to post
Share on other sites

For some time now, I am getting constant crashes from the android app. This isn't too bad when you are just generally browsing, however when it happens when you are in the middle of writing a fairly long reply its irritating. I have taken a bit of time to investigate and have found its always the same errors causing the crash. I run a custom AOSP rom, however I have also been able to recreate the problem on the stock Google ROM.

Issue seems to be related to google analytics implementation and is always the same error causing the crash. See below extract from logcat:

08-14 10:11:00.252 E/AndroidRuntime(30461): FATAL EXCEPTION: disconnect check08-14 10:11:00.252 E/AndroidRuntime(30461): Process: com.tapatalk.fordownersclubcomforums, PID: 3046108-14 10:11:00.252 E/AndroidRuntime(30461): java.lang.IllegalArgumentException: Service not registered: com.google.analytics.tracking.android.AnalyticsGmsCoreClient$AnalyticsServiceConnection@427be62008-14 10:11:00.252 E/AndroidRuntime(30461): 	at android.app.LoadedApk.forgetServiceDispatcher(LoadedApk.java:922)08-14 10:11:00.252 E/AndroidRuntime(30461): 	at android.app.ContextImpl.unbindService(ContextImpl.java:1611)08-14 10:11:00.252 E/AndroidRuntime(30461): 	at android.content.ContextWrapper.unbindService(ContextWrapper.java:529)08-14 10:11:00.252 E/AndroidRuntime(30461): 	at com.google.analytics.tracking.android.AnalyticsGmsCoreClient.disconnect(AnalyticsGmsCoreClient.java:95)08-14 10:11:00.252 E/AndroidRuntime(30461): 	at com.google.analytics.tracking.android.GAServiceProxy.disconnectFromService(GAServiceProxy.java:293)08-14 10:11:00.252 E/AndroidRuntime(30461): 	at com.google.analytics.tracking.android.GAServiceProxy.access$1100(GAServiceProxy.java:27)08-14 10:11:00.252 E/AndroidRuntime(30461): 	at com.google.analytics.tracking.android.GAServiceProxy$DisconnectCheckTask.run(GAServiceProxy.java:367)08-14 10:11:00.252 E/AndroidRuntime(30461): 	at java.util.Timer$TimerImpl.run(Timer.java:284)08-14 10:11:00.252 W/ActivityManager(854):   Force finishing activity com.tapatalk.fordownersclubcomforums/com.quoord.tapatalkpro.ics.slidingMenu.SlidingMenuActivity

My Build info -

build.board: hammerheadbuild.bootloader: HHZ11kbuild.brand: Googlebuild.cpu_abi: armeabi-v7abuild.cpu_abi2: armeabibuild.device: hammerheadbuild.display: KTU84Q test-keysbuild.fingerprint: google/hammerhead/hammerhead:4.4.4/KTU84P/1227136:user/release-keysbuild.hardware: hammerheadbuild.host: dariosf-puritybuild.id: KTU84Qbuild.manufacturer: LGEbuild.model: Nexus 5build.product: hammerheadbuild.radio: unknownbuild.serial: 03a87a2f08eaac8dbuild.tags: test-keysbuild.time: 1407429482000build.type: userbuild.user: dariosfversion.codename: RELversion.incremental: eng.dariosf.20140807.183654version.release: 4.4.4version.sdk_int: 19

I'm not sure who develops your app, however I would appreciate it if you could forward this info onto them for investigation. I have been sending error reports, however the problem has persisted, which has prompted my post here.

Ta!

Higgsy

Share this post


Link to post
Share on other sites

Hi Higgsy,

Unfortunately the Ford OC app is basically just a skin over tapatalk so we don't actually have access to the development of it other than a few basics. Fingers crossed a future update will solve your problems but I will be sure to pass on your findings anyway.

Cheers

James

Share this post


Link to post
Share on other sites

I have no issues with tapatalk, and to be fair never have, i use it constantly to access 8 other forums I use, unfortunately FOC won't allow access via taptalk directly.

FOC app was last updated 09/05, where as tapatalk was last updated yesterday and probably 5 times since May.

FOC app def needs to be updated with the latest sources from tapatalk, however Im not convinced tapatalk in general is at fault, I believe it is google analytics implementation which can be optionally included when you build your own app based on tapatalk. Then again if the code for this is off the shelf then it may well have been fixed in the last 3 months.

Cheers for replying anyway though.

Share this post


Link to post
Share on other sites

Just got an update! Hopefully will address the crashes!

Share this post


Link to post
Share on other sites

Woo hoo been using for the last hour or so and no crashes! Also the app is now remembering the last position you were is when it was last closed ie always opening on Timeline.

jamesm182 likes this

Share this post


Link to post
Share on other sites

Just updated it on my tablet, and it's still crashing/refusing to load threads :-(

I also use the Fiat Forum app (basically the same as the FOC app) and the Tapatalk app with virtually no problems

Share this post


Link to post
Share on other sites

So the update has solved at least some of your problems :)

Will try and see if we can get the updates rolling out a little more regularly.

Share this post


Link to post
Share on other sites

Hey guys

How come the ios version isn't available anymore?

Share this post


Link to post
Share on other sites

I can't find a login box/reply box on the android version.

Share this post


Link to post
Share on other sites

Login is on the menu key, then sign up and login option is there

Sent from my GT-I9195 using Tapatalk

GingerFlame likes this

Share this post


Link to post
Share on other sites

Cheers James, my antiqueness must be kicking in.

jeebowhite likes this

Share this post


Link to post
Share on other sites

Hahaha

Sent from my GT-I9195 using Tapatalk

Share this post


Link to post
Share on other sites

No iOS version anymore? :(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now