Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Daz P

Radio Problem

3 posts in this topic

Hi,

I got in the car this morning to go to work as normal radio working fine but then i actually looked at the radio and there was no display no light no power but the radio was working?

I can operate it from the steering wheel but i have no function on the radio. The power on/off works but thats it.

Its a Zetec on an 11 plate only a recent purchase the radio is a 6000.

Do you think it could be a water ingress problem due to the bad rain we have been getting?

Any help would be much appreciated.

Daz

Share this post


Link to post
Share on other sites
 

It could be a loose ribbon connector inside the radio between the faceplate and the tuner board..

Share this post


Link to post
Share on other sites

More than likely the radio has crashed. The Visteon & sony units are very prone to this.

Pull the fuse and re-insert it - will reset the radio.

Just make sure you have the security code first!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now