Jump to content


Fiesta Mk6 Engine Problem???!

  • Please log in to reply
2 replies to this topic

#1 glenn0708



  • Budding Enthusiast
  • Pip
  • 2 posts
  • Location:

Posted 27 October 2013 - 08:52 PM

Hi guys I'm new to this but need abit of help. A friend bought a car with the cambelt gone I've put new valves and cambelt kit and valve stem oil seals on and the cars running fine but smoking oil out the exhaust loads when I've took the plugs out you can see all the pistons are covered in oil but the piston looked fine any other ideas as these are ment to be bullet proof on the bottom end?

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 jeebowhite


    Resident Loon

  • Super Mod
  • 22,301 posts
  • Name: James
  • Ford Model: Sea Grey Mondeo MKIV 1.8TDCi 140ps Zetec
  • Year: 2007
  • Location: Kent

Posted 28 October 2013 - 01:59 PM

Oil could be out as far as the exhaust, if the heads gone, then the oil could have been thrown out to the exhaust and caked pretty much everyhing inbetween...


Is it blue tint smoke?

#3 mick85


    Too much time on the boards

  • True Ford Enthusiast
  • PipPipPipPip
  • 931 posts
  • Location:

Posted 17 November 2013 - 04:58 PM

Did u replace valve stem oil seals aswell

Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users