Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Sign in to follow this  
Followers 0
covlad1987

failed its mot

10 posts in this topic

hi just got a ford galaxy which failed its mot for £200.00

leaking rear brake caliper

2 spilt cv boots

some play in the ball joint or arm

emissions high

2 front tyres

the rear brake caliper is there a repair kit or a new pattern caliper if so is there a link

cv boots i dont mind doing i might as well change both ball joints and arms at the same time

the emissions is the problem the car had a new oxygen sensor last april,,any idea

Share this post


Link to post
Share on other sites
 

Yes

Is a 2.3 with the auxiliary air injection pump?

If so check that the pump is running. It probably is not. If that is the case then there will be water in it, there is no repair.

It needs the auxiliary air injection pipe replaced with a modified pipe from Ford. It will then need the ECU reflashed by a ford dealer. With modified programing. Witch tells the car how to keep the emissions low without the auxiliary air injection pump operating.

Share this post


Link to post
Share on other sites
Yes

Is a 2.3 with the auxiliary air injection pump?

If so check that the pump is running. It probably is not. If that is the case then there will be water in it, there is no repair.

It needs the auxiliary air injection pipe replaced with a modified pipe from Ford. It will then need the ECU reflashed by a ford dealer. With modified programing. Witch tells the car how to keep the emissions low without the auxiliary air injection pump operating.

sorry its a 2.0 on a 96 plate

think i found why the emission are high

checked the oil today and plugs and air filter looks like its not been do for a long time very black oil and the plugs caked in black crap filter looks black as well and also a hole in the back box

Share this post


Link to post
Share on other sites
can any one tell me what this part is in the pic is

post-974-1239710664_thumb.jpg

Seconday air pump...

Share this post


Link to post
Share on other sites

Seconday air pump...

cheers for that i was wondering what it was im used to the mondeo not the galaxy

Share this post


Link to post
Share on other sites
can any one tell me what this part is in the pic is

post-974-1239710664_thumb.jpg

Thats the pump that im talking about, is it running?

Share this post


Link to post
Share on other sites
Thats the pump that im talking about, is it running?

cheers so i just put my hand on the pump to see if its running

Share this post


Link to post
Share on other sites
cheers so i just put my hand on the pump to see if its running

You should hear it as well. Like a humming nosie. If not then it is what I said before im afraid. :(

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0