Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Sign in to follow this  
Followers 0
daftfunk

Electical Problem

3 posts in this topic

My Ford KA has an electrical problem. When you drive around and use general electrical things ie. lights, radio, wipers etc., the electric slowly dies and fades out until it cuts the engine out and as you're still in motion it jumps itself and all comes back on at full power and then dies again and so on and so on.

Any ideas?

Thanks in advance

Share this post


Link to post
Share on other sites
 

sounds like an alternator problem, check the voltage across the battery terminals with accessories turned on it should read around 13.5 volts.

Share this post


Link to post
Share on other sites
sounds like an alternator problem, check the voltage across the battery terminals with accessories turned on it should read around 13.5 volts.

Well it's all been repaired, the problem was the wiring loom from the alternator. So if you have the same symptoms check that out.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0