Jump to content


Photo

Fault With My 06 Mondeo 2.2 Tdci


  • Please log in to reply
5 replies to this topic

#1 daved413

daved413

    Newbie

  • Budding Enthusiast
  • Pip
  • 2 posts
  • Name: david
  • Ford Model: mondeo 2.2 tdci
  • Year: 2006
  • Location: Durham

Posted 29 October 2013 - 07:18 PM

i was wondering if anyone could help i had a problem a few weeks ago where my car felt like it had the hiccups so after speaking they said to change my fuel filter so i done that which seemed to have worked then the fault came back so i used redex fault went again, but know im starting to think its the glow plugs due to the fact its struggling to start on a morning and very temprementle till its warmed up when i eventually get it started if i dont keep the revs up it will cut out.  so if theres anyone out there that could give me some advice it will be greatly appreciated 

 

Cheers

 

Dave



Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 stooge75

stooge75

    Too much time on the boards

  • True Ford Enthusiast
  • PipPipPipPip
  • 654 posts
  • Ford Model: Mondeo tdci zetec
  • Location: Angus

Posted 30 October 2013 - 11:37 AM

Got any engine light flashing? Any smoke?

#3 daved413

daved413

    Newbie

  • Budding Enthusiast
  • Pip
  • 2 posts
  • Name: david
  • Ford Model: mondeo 2.2 tdci
  • Year: 2006
  • Location: Durham

Posted 30 October 2013 - 12:42 PM

Just a big cloud of smoke when it first starts engine light came on once but not since

#4 stooge75

stooge75

    Too much time on the boards

  • True Ford Enthusiast
  • PipPipPipPip
  • 654 posts
  • Ford Model: Mondeo tdci zetec
  • Location: Angus

Posted 30 October 2013 - 02:22 PM

thats a start as the code will be logged in ECU. have you got anything to read what fault code it is? (elm327 cable,f-super etc).what colour of smoke? white?

ps:dont put any more redex in it. 



#5 jeebowhite

jeebowhite

    Resident Loon

  • Super Mod
  • 17,024 posts
  • Name: James
  • Ford Model: Sea Grey Mondeo MKIV 1.8TDCi 140ps Zetec
  • Year: 2007
  • Location: Kent
Contributor

Posted 30 October 2013 - 02:38 PM

Could be a coked up EGR valve I suppose. We do need more advice though such as colour, does the smoke increase with the revs.



#6 stooge75

stooge75

    Too much time on the boards

  • True Ford Enthusiast
  • PipPipPipPip
  • 654 posts
  • Ford Model: Mondeo tdci zetec
  • Location: Angus

Posted 30 October 2013 - 06:48 PM

any luck getting the eml code?



Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users