• Huge Range of Ford Parts
      Huge Range of Ford Parts
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Get Your Club gear
      Get Your Club gear
    • Share Your Car Experience
      Share Your Car Experience
    • Join Premium & Save
      Join Premium & Save


Muskydo

Mk6 Auto Lights

Recommended Posts

Following from my previous post (suspension noise) another fault my car has just developed is the Auto light function, if I turn the light switch to auto, instead of the lights only coming when light fading they now stay on permanently until switched off. The dash displays message fault with auto lamps and wiper delay, and yes the wiper delay now only works on one speed, are these faults related and why and how do I sort them.

Cheers

Steve

Another fault to follow.........................

Share this post


Link to post
Share on other sites
 

It is quite possible the fault is related as these come as part of the same Pack. The sensors are both together, so I am wondering if it has a sensor issue and both the lights and the wipers have defaulted to at least work.

Share this post


Link to post
Share on other sites

Thanks for reply, I have pulled out all the fuses that appear to have anything to do with these functions but all seam to be good, are any of the relays linked to these functions?

Cheers

Steve

Share this post


Link to post
Share on other sites

Without the schematics I cant tell you. Have you had the windscreen changed at any time

Share this post


Link to post
Share on other sites

No I haven't, why would that effect it, where is the sensor for the auto lights, my wipers are not the rain sensitive type, I've seen the screen on them and the black section behind the mirror is different to mine so I assume that is the rain sensor!

Cheers

Steve

Share this post


Link to post
Share on other sites

Auto light sensor should be on the screen behind the mirror. It is on the Focus so am assuming it is the same on the Fez. Sorry thought that you had auto wipers as well. Could be a relay. They are usually on the reverse side of the fusebox

Share this post


Link to post
Share on other sites

Hi, I've loctaed the sensors behind the glovebox, not being electrically savvy I have no idea how to test there operation, so I think I willneed to visit friendly autoleccy.

Cheers

Steve

Share this post


Link to post
Share on other sites

Something else strange going on with my car regarding lights, I have now owned the car for almost 2 years, today I went to work as normal (in the dark), I had the headlamps on the normal position. When I got to work, stopped the car, turned the lights and wipers off, got out and pressed the button to lock the doors, as I walked away I noticed that the front side lights were still on, thinking I probably hadn't turned the switch far enough I opened the car up again, the switch was in the off position so I turned it to headlamps and then to off again, this time I notice message on display that I hadn't seen before saying "safe home lights" or something very similar, when I got out of the car and re-locked it this time the side and headlamps were still on, I stood and watched and waited for maybe 30 secs or so then they went out. This as never happened before and didn't happen when I returned home either, what is happening here and how to I control it.

Cheers

Steve

Share this post


Link to post
Share on other sites

The safe home lights are normally operated by pulling the stalk back as if to flash the headlights after you have turned the ignition off. This facility is only available with cars that have auto lights are far as I know. If this is happening without you doing that you must either have a dodgy relay somewhere or damp has got into the electrics.

Share this post


Link to post
Share on other sites

Light n rain sensor is one unit. It can't be behind the glove box mate it needs a clear view of the sky and on most modern cars the sensor is behind the rear view mirror under a cover. Take the cover off and check it is connected. Auto lights stay on permanently if it does not detect the sensor so that your lights don't go off in pitch darkness if the sensor is to fail.

Your safe home lights come on when the high beam stalk is pushed into position. After you turn off the ignition just flick the high beam stalk to see the kights stay on for 30 sec. Uou can turn it off by pushing the stalk again. You could have accidently bumped it getting out of the car.

Sent from my GT-I9300 using Ford OC mobile app

Share this post


Link to post
Share on other sites

First thing in the morning I may well of moved the stalk, it's just taken almost 2 years to discover a feature I never knew I had, I'll try it again in the morning, I've quickly read the handbook but couldn't find anything about it. With my autolight sensor is this actually on the mirror and if so how does it get power, My screen is heated and that all works fine.

Cheers

Steve

Share this post


Link to post
Share on other sites

The cables come out from under the roof liner to tje mirror, the plastic covers should hid it all. I retrofitted auto lights and auto wipers to my focus look at ny build thread for an idea of how it looks. Feesta mirror might look different with a different shape sensor

Sent from my GT-I9300 using Ford OC mobile app

Share this post


Link to post
Share on other sites

Thank Kurt, I'll have good look tomorrow in the daylight.

Cheers

Steve

Share this post


Link to post
Share on other sites

G'day from Australia,I drive a Ford Focus xr5 2008 2.5lt turbo ( think its the same model as your mk2 225 ) anyhow I have read your posts about this mod.Have bought the New Windscreen with a new sensor ,Auto light switch, Dimming mirror, just about completed this mod but the auto lights/wipers don't work,The mirror works and there's power to the sensor Do i just need to activated it ,so i'll have to buy one of these ELM plugin thing I guess, cause Ford over here have not heard of the ford xr5s having this optional extra (we aren't as lucky as you folks) , Only our RSs and mk3 Lw models have this optional extra. So I'm puzzled, I've read somewhere that I need a 'Light control module ' this communicates between the sensor and the Auto switch, (I think ) know when to turn on when its raining or getting dark? (its suppose to be under the dash drivers side footwell area held in place by two torx screws (if anyone has a photo of it, in its position I would really appreciate it) has anyone heard of this? or do I just buy this ELM program to activate the Sensor/headlights to work , Please help me finish this project. Cheers Neale

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now