• Get Your Club gear
      Get Your Club gear
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Share Your Car Experience
      Share Your Car Experience
    • Join Premium & Save
      Join Premium & Save
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale


mongman

Map Lights Not Working

4 posts in this topic

I recently bought one of these :

DSCF5307_zpsd84f256c.jpg

and installed it into my Focus Mk2.5. I thought these were plug and play!?

The center light works fine, but neither of the 2 map lights work. I did change the bulbs to LED bulbs, surely they cant both be broken! I have not tested with the original bulbs, is there any other snap on part I need?

Share this post


Link to post
Share on other sites
 

Try turning the LED bulbs around. If they are the push in type they only work one way.

Share this post


Link to post
Share on other sites

They are bayonette type, "wings" on the sides.

Share this post


Link to post
Share on other sites

Thats a shame. All I can think is to try some non LED ones to see if they work if you have any lying around. Have you got a 12v tester to make sure there is power going to those?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now