Jump to content


Photo

Mondeo 2.0 TDCI 130 Juddering/Hesitating - Black Smoke


  • Please log in to reply
3 replies to this topic

#1 jamesknoedl

jamesknoedl

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: Mondeo
  • Location:

Posted 15 April 2009 - 02:45 PM

Hi,

I would be grateful if you could all help me rectify the fault with my Mondeo.

The car is a 2002 Mondeo TDCI 130BHP 2.0TD and has recently started losing power. When driving between a certain amount of revs, the car seems to miss and doesnt have the full power.

I have asked a friend to follow me and they are telling me that the car is putting out excessive black smoke.

Does anyone have any solutions to this.

Thanks

James

Have something to contribute?

Sign in or register to start a topic...

#2 bosnjo

bosnjo

    Newbie

  • New Member
  • Pip
  • 8 posts
  • Ford Model: Mondeo 2.0 TdCI Titanium
  • Location:

Posted 15 April 2009 - 08:27 PM

Hi,

I would be grateful if you could all help me rectify the fault with my Mondeo.

The car is a 2002 Mondeo TDCI 130BHP 2.0TD and has recently started losing power. When driving between a certain amount of revs, the car seems to miss and doesnt have the full power.

I have asked a friend to follow me and they are telling me that the car is putting out excessive black smoke.

Does anyone have any solutions to this.

Thanks

James

The only thing I can think of is the rubber tube that connects Intercooler and EGR Valve. Don't ask me where it is as I'm still waiting for my first Ford (Mondeo) to arrive but by what you've described it's tipical turbodiesel fault. I've had the same problem on my previous Skoda Octavia 2.0 TDI with just 20.000 km on the clock.
Just go to some local mechanic and ask him to check the tube for cracks. You should change it even if it looks OK, it's very cheap, just piece of rubber. If you have many miles on the clock (like 80.000 or more) you'll need good cleaning of EGR Valve as well.

#3 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,457 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 16 April 2009 - 02:49 PM

99% it will be a split in the intercooler pipe, can you here a whoosing noise when the engine is revved? if you can it will be the pipe.

#4 jamesknoedl

jamesknoedl

    Newbie

  • New Member
  • Pip
  • 2 posts
  • Ford Model: Mondeo
  • Location:

Posted 17 April 2009 - 12:29 PM

99% it will be a split in the intercooler pipe, can you here a whoosing noise when the engine is revved? if you can it will be the pipe.



Hi,

Thanks very much for the comments. It worked! The pipe was split near to the rocker cover and was throwing all oil over the fuel injector rail!

Changed the pipe, the car is back to a flyer!

Thanks all!

James


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users