• Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Get Your Club gear
      Get Your Club gear
    • Join Premium & Save
      Join Premium & Save
    • Share Your Car Experience
      Share Your Car Experience
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members


jd1990

Stuck On "ford Audio Welcome" - Media Centre Broken!

Recommended Posts

Hi all,



In a bit of a mess here, the other day I went to go to work, turned my key in the ignition and radio 1 didn't come on as normal, just silence. on the media screen above the radio controls all it said was "Ford Audio Welcome" and was frozen on that with no sound at all. I could turn the media centre on and off as normal, however each time I turned it on all I'd get was that message and in the bottom right hand corner of the media screen there is a constantly lit little red cog (see photos). There has been no disconnecting of the battery and no power drains.



I took it to a ford garage today and they had no idea, and said it would cost over 500 pounds to investigate so I came here hoping someone could shed some light??



Many thanks



Josh



ps. none of the buttons on the left hand side work, including CD eject and all the choices of audio input.



(Ford fiesta Zetec 2009 plate 1.25)



post-48326-0-68238900-1384537371_thumb.jpost-48326-0-51326500-1384537350_thumb.jpost-48326-0-46670700-1384537326_thumb.j


post-48326-0-25451800-1384537590_thumb.j

post-48326-0-52560000-1384537613_thumb.j

post-48326-0-33609300-1384537633_thumb.j

Share this post


Link to post
Share on other sites
 


Now I've just noticed that your display is smaller than mine, and someone pointed out that mine is an upgraded unit, but its not Sony ? I thought they were all the same, but apparently not......

Share this post


Link to post
Share on other sites

I'm going to try to pull the fuse for an hour and will report back. going by the manual it's fuse 21 I need to pull...

watch this space guys!

Share this post


Link to post
Share on other sites

ok, attempted to get to my fuse box which my user guide says is behind the glove compartment. I emptied it, pushed the sides in to gain access but it didn't budge! why can't they make these things easier!

Share this post


Link to post
Share on other sites

A big hammer? ;)

A bit of force is needed. they're quite resilient and will come with effort.

Try hinging the glovebox up a bit from maximum drop and see if maybe there are hooked plastic edges holding onto the dash trim.

Share this post


Link to post
Share on other sites

I guess I will try in the morning with the aid of sunlight. if I can't get to the fuse I will just do the battery. What confuses me is an official ford garage spent all day trying to figure out what the problem was. could the solution be something so simple!? keeping my fingers crossed anyway.

Share this post


Link to post
Share on other sites

My radio was doing all sorts of weird things, and disconnecting the battery worked for me. Does yours have the usb ? If so you could try doing the update through the ford website.

Share this post


Link to post
Share on other sites

Nope my model doesn't have the USB input sadly, only AUX CD and Radio. going to try the battery disconnecting trick this morning and see if that works.

Share this post


Link to post
Share on other sites

Now I've just noticed that your display is smaller than mine, and someone pointed out that mine is an upgraded unit, but its not Sony ? I thought they were all the same, but apparently not......

The larger screen is for bluetooth models, this one isn't.

Share this post


Link to post
Share on other sites

just tried both disconnecting the battery, and taking the fuse out for an hour, and no luck! :( any other suggestions?

Share this post


Link to post
Share on other sites

Hi, I got my fiesta last week and the sat nav/lighter socket wasn't working, so after replacing the fuse for that my radio decided to stop working. At first was stuck on passenger/driver door open, now stuck on ford audio welcome. I tried disconnecting the battery for an hour, no luck! Did anyone come up with a solution to this problem?

Share this post


Link to post
Share on other sites

Did anyone find out what the problem was because my stereo is doing the same 😟 I bought a new stereo and that says the same, it's really annoying!!!

Share this post


Link to post
Share on other sites

Same here... had issues with my cigarette lighter not working, removed the fuse and now it works with no fuse in the slot...

Then the stereo started to stay on after I switched the car off and even after switching it off manually the screen would stay on and kill my batter

AND now my stereo won't work at all.... just says ford audio and won't play anything or connect to bluetooth....

 

Mk7 2012 fiesta

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now