Jump to content


Show
Photo

Car Wont Start, Advice Needed!

car wont start ford focus mk2.5 zetec s

  • This topic is locked This topic is locked
16 replies to this topic

#1 ELushion

ELushion

    Newbie

  • Budding Enthusiast
  • Pip
  • 8 posts
  • Name: Matthew
  • Ford Model: Ford Focus MK2.5 Zetec S
  • Year: 2011
  • Location: Antrim

Posted 15 November 2013 - 11:55 PM

Hi, so just went to start my car and no luck. Weird. It was fine when I left it!!

 

So I push the start button and nothing is happening. Weirdest part is, the little display on the dashboard is not showing anything either except time and milage. Its not displaying that the doors open, that the keys missing. Nothing in the middle bit. Its just showing this (below) and its also not dimming, even when the cars locked the dashboard display still stays light!

 

Its a Ford Focus MK2.5 2011 Zetec S btw!

 

24vsoco.jpg



Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 Preee

Preee

    Ford Fruitcake

  • Moderator
  • 4,098 posts
  • Name: Paul
  • Ford Model: Focus Tit X Mk3 | Fiesta Zetec Mk7
  • Year: 2012
  • Location: Shropshire
Contributor

Posted 16 November 2013 - 11:19 AM

have you got a tester to see the voltage of the battery ? Damp weather could have caused it to discharge.



#3 ELushion

ELushion

    Newbie

  • Budding Enthusiast
  • Pip
  • 8 posts
  • Name: Matthew
  • Ford Model: Ford Focus MK2.5 Zetec S
  • Year: 2011
  • Location: Antrim

Posted 16 November 2013 - 11:27 AM

No I dont. But all the lights still work, even the radio so there must be charge?

 

I just disconnected the battery there now in an attempt to reset the electricals, the wee dashboard display went off( had been on all night). So gonna leave it 15minutes then  reconnect.



#4 Preee

Preee

    Ford Fruitcake

  • Moderator
  • 4,098 posts
  • Name: Paul
  • Ford Model: Focus Tit X Mk3 | Fiesta Zetec Mk7
  • Year: 2012
  • Location: Shropshire
Contributor

Posted 16 November 2013 - 11:30 AM

You still need a certain battery level before the car will start even if the lights are still working , also check all your fuses.



#5 ELushion

ELushion

    Newbie

  • Budding Enthusiast
  • Pip
  • 8 posts
  • Name: Matthew
  • Ford Model: Ford Focus MK2.5 Zetec S
  • Year: 2011
  • Location: Antrim

Posted 16 November 2013 - 11:32 AM

The weird part is. You know the wee display that I have pictured. When I open the car, it doesnt show door open, doesnt show key not found. If I press the stalk it beeps, but still shows nothing.

 

What am I looking for on the fuses, is there a sign ones blown?



#6 Preee

Preee

    Ford Fruitcake

  • Moderator
  • 4,098 posts
  • Name: Paul
  • Ford Model: Focus Tit X Mk3 | Fiesta Zetec Mk7
  • Year: 2012
  • Location: Shropshire
Contributor

Posted 16 November 2013 - 11:36 AM

check under bonnet fuses and passenger foot well fuses , you need to pull them out one by one , as they are not easy to see it they are blown.



#7 ELushion

ELushion

    Newbie

  • Budding Enthusiast
  • Pip
  • 8 posts
  • Name: Matthew
  • Ford Model: Ford Focus MK2.5 Zetec S
  • Year: 2011
  • Location: Antrim

Posted 16 November 2013 - 11:37 AM

Fantastic lol, them buggers under the footwell are a pain in the ^&% to pull out. Cheers for the help!

 

So annoyed at this!



#8 ELushion

ELushion

    Newbie

  • Budding Enthusiast
  • Pip
  • 8 posts
  • Name: Matthew
  • Ford Model: Ford Focus MK2.5 Zetec S
  • Year: 2011
  • Location: Antrim

Posted 16 November 2013 - 12:03 PM

Well! That worked!!

 

I have two questions though.

 

1. How long does the wee dash display stay lit normally?

 

2. My radio now needs a code, a V code.. is the only way dealer or ebay?



#9 Preee

Preee

    Ford Fruitcake

  • Moderator
  • 4,098 posts
  • Name: Paul
  • Ford Model: Focus Tit X Mk3 | Fiesta Zetec Mk7
  • Year: 2012
  • Location: Shropshire
Contributor

Posted 16 November 2013 - 01:48 PM

Did you find a blown fuse?

 

1) dash stays on for approx 10 minutes after you lock the car.

 

2) V code is dealer



#10 ELushion

ELushion

    Newbie

  • Budding Enthusiast
  • Pip
  • 8 posts
  • Name: Matthew
  • Ford Model: Ford Focus MK2.5 Zetec S
  • Year: 2011
  • Location: Antrim

Posted 16 November 2013 - 02:57 PM

I never checked for a fuse! Once I disconnected, and reconnected the battery all is working again. The wee dash even goes off at 10 mins..

 

Very weird!



#11 stooge75

stooge75

    Too much time on the boards

  • True Ford Enthusiast
  • PipPipPipPip
  • 654 posts
  • Ford Model: Mondeo tdci zetec
  • Location: Angus

Posted 16 November 2013 - 03:22 PM

Ah good.glad to hear it

#12 ELushion

ELushion

    Newbie

  • Budding Enthusiast
  • Pip
  • 8 posts
  • Name: Matthew
  • Ford Model: Ford Focus MK2.5 Zetec S
  • Year: 2011
  • Location: Antrim

Posted 16 November 2013 - 03:24 PM

Lyndsay Ford however, pack of #####. Want to charge me £15 for them to tell me the serial code code they have wrote down for my radio!! Scandal! lol

I will send you over the number here now mate, thansk!


Edited by Stoney871, 16 November 2013 - 06:07 PM.
inappropriate language


#13 Preee

Preee

    Ford Fruitcake

  • Moderator
  • 4,098 posts
  • Name: Paul
  • Ford Model: Focus Tit X Mk3 | Fiesta Zetec Mk7
  • Year: 2012
  • Location: Shropshire
Contributor

Posted 16 November 2013 - 05:21 PM

* A Reminder that sharing radio Codes on this Forum or via PM is not allowed. People doing so will be dealt with accordingly and reported to management.



#14 stooge75

stooge75

    Too much time on the boards

  • True Ford Enthusiast
  • PipPipPipPip
  • 654 posts
  • Ford Model: Mondeo tdci zetec
  • Location: Angus

Posted 16 November 2013 - 05:22 PM

what we do via email is nothing to do with this forum no?and whats our PM's gotta do with you? if i know someone at ford who can get him it,whats the problem??



#15 Preee

Preee

    Ford Fruitcake

  • Moderator
  • 4,098 posts
  • Name: Paul
  • Ford Model: Focus Tit X Mk3 | Fiesta Zetec Mk7
  • Year: 2012
  • Location: Shropshire
Contributor

Posted 16 November 2013 - 05:26 PM

The problem is sharing codes via this Forum , it was stopped and only brings more people wanting radio codes , you can do what you want via your own Email but not via this forum.



Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have




Also tagged with one or more of these keywords: car, wont, start, ford, focus, mk2.5, zetec s

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users