Jump to content


Photo

KA cabin too hot


  • Please log in to reply
3 replies to this topic

#1 AndyWhitlock

AndyWhitlock

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Ford Model: KA
  • Location:

Posted 16 April 2009 - 08:55 AM

Hi Guys

I've got a '98 Ka and after about 10 minutes of driving the air from the fans (even when closed) becomes warm. This fills the cabin so that I have to open the windows to get some cooler air in. I've not got air conditioning so this won't be very pleasant in the summer!

I've heard it may be a symptom of the head gasket going, although I did have a similar problem with another Ka previously although to a lesser degree and that car had no mechanical issues at all.

Have other people had this problem or could it be something more serious than just a poor fan system?

Hope someone can help!

Andy

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 delboy

delboy

    Too much time on the boards

  • True Ford Enthusiast
  • PipPipPipPip
  • 536 posts
  • Name: martin
  • Ford Model: c-max ghia 1.8 petrol /ka 1.2 mk2
  • Year: 2004
  • Location: Somerset

Posted 16 April 2009 - 04:23 PM

check to see if the pollen filter is blocked
it's located the passenger side of the car under the bulk head about 6-8 inches long

#3 wilbur

wilbur

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Ford Model: ka
  • Location:

Posted 20 April 2009 - 10:12 PM

Hi Im interested in replies, as I have a 04 and have exactly the same problem as you have, I was told it could be heater control valve so i got a new one and a friend replaced it, but unfortunately it didnt work,good luck.



Hi Guys

I've got a '98 Ka and after about 10 minutes of driving the air from the fans (even when closed) becomes warm. This fills the cabin so that I have to open the windows to get some cooler air in. I've not got air conditioning so this won't be very pleasant in the summer!

I've heard it may be a symptom of the head gasket going, although I did have a similar problem with another Ka previously although to a lesser degree and that car had no mechanical issues at all.

Have other people had this problem or could it be something more serious than just a poor fan system?

Hope someone can help!

Andy



#4 hendrix

hendrix

    Feet Under The Table

  • New Member
  • PipPipPipPip
  • 128 posts
  • Ford Model: fusion uk

Posted 21 April 2009 - 01:09 PM

We had this problem in our old ka also. the heaters thermo is knakered and they stick on. we never had it fixed as you have to remove dash and all sorts and then was told that may not fix it. They did a trick for us where its either permanent cold or hot. That got us thruogh the six mnths before we traded it.


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users