• Share Your Car Experience
      Share Your Car Experience
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Get Your Club gear
      Get Your Club gear
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Join Premium & Save
      Join Premium & Save
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale


Katiemc1989

Help Heaters Don't Work

8 posts in this topic

My heaters don't work on my streetka , when I've been driving for about 30mins I can feel a little bit off heat getting blown throu the heaters but nothing much even when the heaters are all switched off . Could it be the heater control valve and are the heaters all the same on the ka's

Share this post


Link to post
Share on other sites
 

same as the fiestas just below the bulk head.

this will give you an idea

Share this post


Link to post
Share on other sites

Do it sound like the heater control valve or something else

Share this post


Link to post
Share on other sites

It does sound like the HCV. If it was the thermostat it would warm up more when stationary and cool down when in motion. HCV's are such a common problem it is always going to be the most likely culprit.

Share this post


Link to post
Share on other sites

Thank you will be ordering one tomorrow off ebay

Share this post


Link to post
Share on other sites

it may also be this part thats playing up but its only gone when there is no blowers working apart from setting 4 from memory.

this part is located under the passengers footwell by 1 screw under glove compartment

http://www.ebay.co.uk/itm/like/190851067725?hlpht=true&ops=true&viphx=1&lpid=95&device=c&adtype=pla&crdt=0&ff3=1&ff11=ICEP3.0.0&ff12=67&ff13=80&ff14=95&ff19=0

here is ford link for the part and prices remember you got to add vat to the prices

http://www.fordpartsuk.com/shop/ford_fiesta_heater_resistor_f_1104100_c_278.htm

Share this post


Link to post
Share on other sites

i had to change my heater control valve a few months back when mine had gone though i only had cold air. hope that be of some help.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now