• 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Get Your Club gear
      Get Your Club gear
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Share Your Car Experience
      Share Your Car Experience
    • Join Premium & Save
      Join Premium & Save

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


KAR

Powershift Revs Up And Down And Other Problems

3 posts in this topic

Several problems from PowerShift. (1) When driving at constant speed with constant pressure on throttle revs go up and down by 100/200 rpm every half second. I've uploaded a video at http://youtu.be/3Wxt-lXkZiU. When revs drop engine gets louder. (2) Gear changes are rough - in drive and manual. (3) Cold start there is often a clunk coming from the engine as if it is in D even though it is in P. Sometimes there is a crashing of gears. No levers or peddles are touched. (4) Occasional tapping sound from gearbox every half second when stationery then speeds up when in motion. Occasionally accompanied by hot smell from under the car (not the engine). I've been to Ford dealer but car always behaves itself when at the dealer.

Share this post


Link to post
Share on other sites
 

got similar rev counter issues with my 2010 galaxy but none of the other gearbox symptoms. Did you get anything sorted?

Share this post


Link to post
Share on other sites

Sorry for delay in replying: been on vacation. The problem got worse. Car started to display 'Transmission Limited Function' after which only gears 1+3+5 would work or just 2+4+6. Switch off and on again and all gears worked though initial problems continued. Eventually had to have clutches replaced by Ford dealer. Cost £1200. That fixed problem (1) in original post and initially problems (2) + (3), but (2) + (3) came back. Then one day 'Transmission Limited Function' warning appeared and display said car was in gear 7!!! Car went back to dealer. It took the dealer two weeks to find out what was wrong. It turned out that when the clutch was replaced the speed sensor should have been replaced as well. It then took dealer a few weeks to get the part and fit. Dealer did this free of charge and gave me a free major service. This fixed (2) and (3). Issue (4) continued infrequently until I eventually worked out it was the cooling fan! I have no idea why the issue (4) tapping sound speeds up when the car speeds up because I would have thought the cooling fan would spin constantly, but it only occurs when the fan is on.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now