Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


n1xsta

Please Help Guys And Advice

5 posts in this topic

Hi guys need advice,

Brought a 2001 tddi 2.0 Mondeo Zetec the other day more as a project.

My turbo doesn't seem to kick in at all and the car seems really sluggish.

I am driving with my foot down and feels I'm driving a 1.0 engine in my big car. There is nothing at all it just goes up slowly. There is no misfiring or anything.

The car was used on a farm and have fixed the oil pressure switch and the rear wheel bearing hub will be doing a service On the car next week but this is my next mission.

Any ideas welcome please

Share this post


Link to post
Share on other sites
 

check all the rubber hoses for signs of damage as this could cause a loss of boost,also check the sensor in the hose under the rad.

Share this post


Link to post
Share on other sites

Do you hear any weird whistles or whines when your foot is attached to the floor?

Share this post


Link to post
Share on other sites

No I don't

Share this post


Link to post
Share on other sites

So it would appear that you dont have any cracks in the intercooler pipes or hoses. It sounds like the turbo might just be dead (presuming you have one!?)

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now