Jump to content


Show
Photo

Speedo, Rev Counter And Trip Problem


  • Please log in to reply
2 replies to this topic

#1 schmoo_smith

schmoo_smith

    Newbie

  • Members via FB
  • Pip
  • 2 posts
  • Name: Martin
  • Ford Model: SportKa
  • Year: 2004
  • Location: Wiltshire

Posted 08 December 2013 - 07:22 PM

Hi all

 

I recently bought a SportKa from a mate, the car had previously been sat for 3 months, the battery was dead so we had to jump start the car to get it running. The car runs no problem at all now. The only issue I am having is that whenever I start the car the speedo and rev counter are ticking like mad for a few seconds, thefuel gauge drops down and back up and also the trip resets itself, this is happening every time I start the car. I did a video of the issue, here is the link: 

 

Many thanks in advance for your help.

 

Martin

 


Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 schmoo_smith

schmoo_smith

    Newbie

  • Members via FB
  • Pip
  • 2 posts
  • Name: Martin
  • Ford Model: SportKa
  • Year: 2004
  • Location: Wiltshire

Posted 13 December 2013 - 10:49 AM

** PROBLEM SOLVED**

 

All it needed was a new battery.



#3 jeebowhite

jeebowhite

    Resident Loon

  • Super Mod
  • 15,516 posts
  • Name: James
  • Ford Model: Sea Grey Mondeo MKIV 1.8TDCi 140ps Zetec
  • Year: 2007
  • Location: Kent
Contributor

Posted 13 December 2013 - 12:10 PM

Was just about to say that! lol, yeah this is a classic symptom of batterius fluffed'us!




Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users