Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Valleyboy22

Radio Stuck On Phone? ?

22 posts in this topic

Hey guys I was gonna pick up my 58 plate focus from the garage today but they rang and said the radio is stuck on phone mode? They said I can still get the car but it's booked into ford this week so I think it's pointless getting it until sorted. This a common fault because I don't want a temp fix from the garage if a month down the line it does it again.

Cheers

Share this post


Link to post
Share on other sites
 

The radio just needs to be reset by pulling the fuse or disconnecting the battery.

Ensure you have the radio code first.

Share this post


Link to post
Share on other sites

Thanks for the reply and why has this done it though because im wondering if its a stereo fault and don't want to have the car for a month and does it again?

Share this post


Link to post
Share on other sites

It's usually a pulse down the mute sensor wire that activates when a phone button is pressed.

It can happen occasionally but is pretty rare tbh.

Share this post


Link to post
Share on other sites

Brill thanks for that.

Sent from my GT-I9505 using Ford OC mobile app

Share this post


Link to post
Share on other sites

well I was suppose to be picking up my 58 plate new focus but had a problem with the stereo on Monday and seems still is. I was told to get the car Monday but a radio fault on the car which says its stuck on phone mode I thought was sorted. when to get the car today and its done it again and now the radio wont turn off and the dashboard light also wont turn off?? The garage are giving me a courtesy car until its been sorted in the ford garage. I hope this is not a bad omen on me getting this car? Clearly something wrong with the stereo and funny how its now affected the light on the dashboard?

Oh well fingers crossed it will be sorted before xmas??

Share this post


Link to post
Share on other sites

Surprised that they still havet got it sorted.

I am going to merge your threads though, put them all in one place!

Share this post


Link to post
Share on other sites

Yeah me to I'm gutted. Thanks

Sent from my GT-I9505 using Ford OC mobile app

Share this post


Link to post
Share on other sites

well they have sent my stereo to be fixed I was told today so fingers crossed they sort it and I can pick my new car up. !Removed! courtesy car is tiny and no good as a family car in which I need.

Share this post


Link to post
Share on other sites

well at least they have sent it off... took long enough like!

Why dont you take the car as it is without a stereo for the short term? at least that way you get your car, with the comforts for the family, ok it will be a bit quiet :p but at least you get it for more often!

Share this post


Link to post
Share on other sites

Glad it is eventually been sent off. The reason I did not have it on Friday was the stereo done the phone thing again but this tine it would not turn off and the light on the dash also stayed on so would of drained the battery. Rather get the car when all sorted, and think I will put up with the corsa knowing hopefully I will leave Evans Halshaw with a sorted car.

Sent from my GT-I9505 using Ford OC mobile app

Share this post


Link to post
Share on other sites

They should give you a car suitable for your needs.

Share this post


Link to post
Share on other sites

That's all they had at the time, so hopefully I won't have it long anyway.

Sent from my GT-I9505 using Ford OC mobile app

Share this post


Link to post
Share on other sites

the cluster light wont drain the battery, I live with it daily lol!

Share this post


Link to post
Share on other sites

Oh right I did not know that lol. Well I will wait until end of the week to see if sorted and if not I will pick it up anyway I think otherwise I prob won't ave it until after Xmas lol.

Sent from my GT-I9505 using Ford OC mobile app

Share this post


Link to post
Share on other sites

lol, thats fair enough fella.

I have an issue I am investigating at the moment on my car with the cluster. Its lit up like a christmas tree 24/7. I drive the car all week to work, so the battery always gets a good topup, but I have left it for 4 days straight without touching it, the light was on, I had other LED's on (12v extension lead, with my parking sensors plugged into it) along with an OBDII connector plugged in and lighting up its own LED, as well as the usual immobiliser. Never had an issue starting it.

If you do want it without the radio, I really wouldnt worry about the battery being killed off by it. Look at it this way. The garage wont have disconnected the battery for you, so it will be sat there now with the cluster on, I doubt they will have any problems.

Share this post


Link to post
Share on other sites

With the cluster u mean the gage with milage on etc? Well if that still happens when the radio is so called Fixed on the dash I'm not taking the car. It was not doing that when looking at car so I hoping it's something to do with the radio. Hope this is not a omen not to have this car??

Sent from my GT-I9505 using Ford OC mobile app

Share this post


Link to post
Share on other sites

I am not sure, but I believe that their is a potential issue with aftermarket headunits and the cause of this. As long as its the original though, it shouldnt be a problem.

Share this post


Link to post
Share on other sites

I read somewhere on the net there was a issue with the radios.

Sent from my GT-I9505 using Ford OC mobile app

Share this post


Link to post
Share on other sites

well I was told that I have a new stereo fitted in my car and all ok,so gonna pick it up tomorrow. fingers crossed that problem is all sorted and can enjoy my first ford focus.

Share this post


Link to post
Share on other sites

Hope that its all well Chris!

Share this post


Link to post
Share on other sites

Thanks

Sent from my GT-I9505 using Ford OC mobile app

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now