Jump to content


Photo

Mk4 Mondeo 2.2 Tdci


  • Please log in to reply
3 replies to this topic

#1 tdcitony

tdcitony

    Newbie

  • Budding Enthusiast
  • Pip
  • 5 posts
  • Name: tony
  • Ford Model: mondeo mk4 2.2 titanium x sport
  • Year: 2009
  • Location: Durham

Posted 12 December 2013 - 11:18 PM

anyone help car stalled now wont turn over checked fuses and starter and they are fine all i get is a relay clicking



Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 mick85

mick85

    Too much time on the boards

  • True Ford Enthusiast
  • PipPipPipPip
  • 908 posts
  • Location:

Posted 13 December 2013 - 12:58 AM

Have u lights on the dash if battery good an it won't crank at all u have to test starter solenoid could be gone more info if u can

#3 tdcitony

tdcitony

    Newbie

  • Budding Enthusiast
  • Pip
  • 5 posts
  • Name: tony
  • Ford Model: mondeo mk4 2.2 titanium x sport
  • Year: 2009
  • Location: Durham

Posted 13 December 2013 - 08:25 AM

Just the normal lghts on the dash no warning lights .solenoid checked and spot on, clutch switch is working as it should but the starter relay is not switching to live and earth it is live both side so not switching over but if I put my probe onto earth side and earth my probe it turns over off the start switch but wont fire up

#4 tdcitony

tdcitony

    Newbie

  • Budding Enthusiast
  • Pip
  • 5 posts
  • Name: tony
  • Ford Model: mondeo mk4 2.2 titanium x sport
  • Year: 2009
  • Location: Durham

Posted 13 December 2013 - 08:28 AM

All fuses checked and are fine all you get when pressing start button is a relay in the boot and one under the bonnet clicking no lights dimming when presing it


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users