Jump to content


Photo

Hit A Kurb Hard Help!!


  • Please log in to reply
18 replies to this topic

#1 headsy132050

headsy132050

    Member

  • Budding Enthusiast
  • PipPip
  • 15 posts
  • Location:

Posted 21 December 2013 - 07:55 PM

Last night i swerved to avoid and idiot driving a bus in my lane , i hit a kurb real hard and it blew my tyre and smashed a rim. I took wheel off and noticed there was a black bottle container thing in front of my wheel has snapped and is hanging down , the car seems fine otherwise but i am worried i have done some damage elsewhere

Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 FOCA

FOCA

    Feet on the table

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 2,867 posts
  • Name: FOCA
  • Ford Model: Mondeo Mk3 Sleeper 194 flb.p.t.
  • Year: Non
  • Location: Scotland
Contributor

Posted 21 December 2013 - 08:05 PM

1 - need pictures

 

2 - what model of car do you have

 

Without the nessesary information it is difficult to tell what the black bottle thing is that broke, but it may be part of the aircon system

 

We call them kerbs in the UK

 

Enjoy -

 

http://www.oxforddic...on/english/kerb



#3 headsy132050

headsy132050

    Member

  • Budding Enthusiast
  • PipPip
  • 15 posts
  • Location:

Posted 21 December 2013 - 08:11 PM

How do i put a pic on? Its 1.6 petrol zetec 2006. Yeah im in the uk too :)

#4 FOCA

FOCA

    Feet on the table

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 2,867 posts
  • Name: FOCA
  • Ford Model: Mondeo Mk3 Sleeper 194 flb.p.t.
  • Year: Non
  • Location: Scotland
Contributor

Posted 21 December 2013 - 08:24 PM

How do i put a pic on? Its 1.6 petrol zetec 2006. Yeah im in the uk too :)

If you go to "more reply options" then "attach files/ choose files" you can upload j-pegs from you PC



#5 headsy132050

headsy132050

    Member

  • Budding Enthusiast
  • PipPip
  • 15 posts
  • Location:

Posted 21 December 2013 - 08:27 PM

Ok thanks, there is a pic , looks like somethjng is snapped off like a pipe, the whole unit is loose and i can hear water swishing around inside car :/

#6 headsy132050

headsy132050

    Member

  • Budding Enthusiast
  • PipPip
  • 15 posts
  • Location:

Posted 21 December 2013 - 08:29 PM

image.jpg {{{{ sorry here is pic

#7 headsy132050

headsy132050

    Member

  • Budding Enthusiast
  • PipPip
  • 15 posts
  • Location:

Posted 21 December 2013 - 09:26 PM

Any ideas?

#8 jeebowhite

jeebowhite

    Resident Loon

  • Super Mod
  • 21,131 posts
  • Name: James
  • Ford Model: Sea Grey Mondeo MKIV 1.8TDCi 140ps Zetec
  • Year: 2007
  • Location: Kent
Contributor

Posted 21 December 2013 - 09:31 PM

Looks to me like possibly the ECU cover? just looks like the bracket has snapped?



#9 headsy132050

headsy132050

    Member

  • Budding Enthusiast
  • PipPip
  • 15 posts
  • Location:

Posted 21 December 2013 - 09:32 PM

Yeah the bracket is snapped is there anything missing and is it serious?

#10 jeebowhite

jeebowhite

    Resident Loon

  • Super Mod
  • 21,131 posts
  • Name: James
  • Ford Model: Sea Grey Mondeo MKIV 1.8TDCi 140ps Zetec
  • Year: 2007
  • Location: Kent
Contributor

Posted 22 December 2013 - 08:26 AM

All looks to be there, just that bit broken.



#11 headsy132050

headsy132050

    Member

  • Budding Enthusiast
  • PipPip
  • 15 posts
  • Location:

Posted 22 December 2013 - 08:40 AM

Thanks, will get a new one , what does it do by the way?

#12 headsy132050

headsy132050

    Member

  • Budding Enthusiast
  • PipPip
  • 15 posts
  • Location:

Posted 22 December 2013 - 08:46 AM

P.s this pic is under neath the car , passenger side infront of the wheel

#13 jeebowhite

jeebowhite

    Resident Loon

  • Super Mod
  • 21,131 posts
  • Name: James
  • Ford Model: Sea Grey Mondeo MKIV 1.8TDCi 140ps Zetec
  • Year: 2007
  • Location: Kent
Contributor

Posted 22 December 2013 - 09:35 AM

I would suggest that you will want a garage to look at it and confirm I can't get at microcat at the moment but I think it's just the the cars ECU storage. if you broke that though you probably broke more.

sent using the Ford OC app for android.



#14 Nathan_M

Nathan_M

    Too much time on the boards

  • Members via Twitter
  • PipPipPipPip
  • 912 posts
  • Name: Nathan
  • Ford Model: Fiesta Flame Mk6
  • Year: 2004
  • Location: Cornwall

Posted 22 December 2013 - 11:26 AM

Where did you take this picture from? I can't tell what any of that is. Haha Edit* I forgot how to read, on mine there is a black plastic box similar to that beside the battery and below the ecu not entirely sure what it does all I know is that it has an input so must do something handy, just make sure it's secure if everything is working okay, ad for the water noise check the coolant expansion bottle hasn't jumped off of its hooks it moves quite easily. Sent from my GT-N5110 using Ford OC mobile app

#15 headsy132050

headsy132050

    Member

  • Budding Enthusiast
  • PipPip
  • 15 posts
  • Location:

Posted 23 December 2013 - 05:47 PM

Hey guys thanks for your help, just an update, turns out its the airbox resonator, now for my next question haha , can this ne removed? And not replaced? I read on a few forums that ppl remove them as a mod to there focus thanks guys :P been quoted 180 to replace

Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users