Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


josrey

1.4Tdci 2010 Fiesta Running Rough And Smoking On Start??

7 posts in this topic

Got a 2010 mk7 fiesta and it's running rough and smoking on start up garage said it could either injector 3 not working or a bent conrod has anyone had any experience of this or can help on the matter as I do t wanna fork out £2k if it's the conrod

thanks in advance

Share this post


Link to post
Share on other sites
 

Sounds like a leaking injector to me.

Fuel pooling in the cylinder when off would cause smoke and roughness until burned off.

Share this post


Link to post
Share on other sites

Thanks a lot that is what I wanted to hear really don't wanna send £2k on a new engine!!

Share this post


Link to post
Share on other sites

Agree with Stoney wats ur mileage also might be worth checking glow plugs they could be gone as well an making symptoms worse

Share this post


Link to post
Share on other sites

Agree with Stoney wats ur mileage also might be worth checking glow plugs they could be gone as well an making symptoms worse

Mileage is only 48k so not done a million miles and I will check the glow plugs anything that can cure this will be good :)

Share this post


Link to post
Share on other sites

Well they very easy to test but u are ment change every few years an don't think they the handiest to change so if u not stuck for cash I would replace could prevent further problems down the line

Share this post


Link to post
Share on other sites

Update on this issue its not the injector it was sent off to a diesel injector specialist and they have said its working fine head is coming off as i write this!!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now