• Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Get Your Club gear
      Get Your Club gear
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Join Premium & Save
      Join Premium & Save
    • Share Your Car Experience
      Share Your Car Experience
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale


wijcc

Electric Window Not Working

Recommended Posts

My front drivers side electric windows has stopped working... it was working fine this morning however this evening on the way home it has stopped working. The front passenger side window is working fine.. from both the controls on the passengers side and drivers side control/buttons..
The car is a 2001 ford focus... it only has electric front windows. What do i need to check.. is there a separate fuse for each window or anything like that.. I simple fix or something?
Thanks in advance guys

Share this post


Link to post
Share on other sites
 

Check fuses first then remove door card use circuit tester or multimeter check u getting voltage down to reg block connector if u don't most likely switch is problem

Share this post


Link to post
Share on other sites

Thanks.... is there one fuse for both electric windows... or a separate fuse for each window.

The passenger side window works from the controls on the drivers door.

Thanks again

Share this post


Link to post
Share on other sites

U really need circuit tester at the least u can buy for less den 20 if u mess round with car electrics circuit test an a multimeter are a must for diagnostics the will save u money in long run

Share this post


Link to post
Share on other sites

Thanks... checked the fuses. All of those ones are fine. Fuse no 56 is the one for the electric windows.

When I press the button for the drivers side window it makes one click noise but nothing happens. when i press the button for the passenger window from the same control panel it works.

So does this sound like the motor for the drivers side window has died?

Share this post


Link to post
Share on other sites

Got a replacement 2 pin drivers side window motor and regulator for 02
focus. New part doesn't have the electrical connector attached to the
motor. Instead has two wires with pins. Is it simply a matter of
swapping the old connector over to the new part or have I the wrong
part?

Share this post


Link to post
Share on other sites

Compare the part numbers of the old and new regulator but it sounds like the wrong one to me. Either that, or you might find that the casing is on the wiring side and that the existing regulator plugs in the same way.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now