Jump to content


Show
Photo

Mk3 Diesel Climate Control Issues


  • Please log in to reply
4 replies to this topic

#1 tp31793

tp31793

    Newbie

  • Budding Enthusiast
  • Pip
  • 3 posts
  • Location:

Posted 03 January 2014 - 08:31 PM

Hi I'm having problems with my climate control the car heats up intermittently all the buttons work on it the temp gauge works on the car it can be working then suddenly stops or it just doesn't work at all any ideas and body plz

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 ppeter7

ppeter7

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 328 posts
  • Name: peter
  • Ford Model: mondeo 1.8/ mondeo 2.0 zetec
  • Year: 2001
  • Location: Devon

Posted 03 January 2014 - 09:04 PM

are we talking about the temp gauge drops to zero or are we talking about the lcd heater controls pack up



#3 tp31793

tp31793

    Newbie

  • Budding Enthusiast
  • Pip
  • 3 posts
  • Location:

Posted 03 January 2014 - 09:55 PM

No the temp gauge stays the same you can have the LCD saying 20 degrees and it will be working then next the heater starts blowing cold

#4 jeebowhite

jeebowhite

    Resident Loon

  • Super Mod
  • 16,187 posts
  • Name: James
  • Ford Model: Sea Grey Mondeo MKIV 1.8TDCi 140ps Zetec
  • Year: 2007
  • Location: Kent
Contributor

Posted 06 January 2014 - 01:49 PM

Sounds like the resistor pack probably needs replacing...



#5 tp31793

tp31793

    Newbie

  • Budding Enthusiast
  • Pip
  • 3 posts
  • Location:

Posted 06 January 2014 - 07:46 PM

Cheers I'll replace it and see how it goes


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users