• 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Get Your Club gear
      Get Your Club gear
    • Share Your Car Experience
      Share Your Car Experience
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Join Premium & Save
      Join Premium & Save

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Dovermondeo

Injector Issues 05 Tdci

3 posts in this topic

Hello everyone, this is my first post and I'm hoping someone can help me please, my mondeo cuts out whenever I put it under any load, I have replaced the cam sensor but no change, I performed a leak off test today, I used 100ml bottles and they were nearly full in30 seconds on tick over, does this mean all of te injectors are faulty or am could it be something else? Please help post-49601-0-37983200-1388941454_thumb.j

Share this post


Link to post
Share on other sites
 

As far as I know you shouldn't be getting more than 20-30ml per injector.

Share this post


Link to post
Share on other sites

Hi thanks for reply, this shouldn't of happened over 20 seconds should it?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now