• Share Your Car Experience
      Share Your Car Experience
    • Join Premium & Save
      Join Premium & Save
    • Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Get Your Club gear
      Get Your Club gear
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


MM92

Dashboard Lights & Needles Playing Up

35 posts in this topic

unfortunately I cant say I have seen or know if its screw or not, I believe though it would probably just be lugs.

If you can see screws, unscrew it to be on the safe side.

Share this post


Link to post
Share on other sites
 

Been looking about a bit more, seems as if the black plastic part lifts then swings over the white 'gate' to release.

I'll give it another go wednesday but has been a pattern of not working when the car is damp!

Share this post


Link to post
Share on other sites

Hi,

Just had another go at it, followed the video on Youtube where it just unclips but mine's not budging!

Any ideas?

On the first image you can see a little white bit stopping the black 'U' clip from moving as it does in the video.

focus1.jpg

focus2.jpg

Share this post


Link to post
Share on other sites

Giving at a clean as we speak but if this fails after it's dried out etc I'm going to need to take the ECU out and send off.

How much of a pain is the ECU to remove and also where isit?

Share this post


Link to post
Share on other sites

An easy way to check if you have the cluster issue is with a computer and one cable . Then get a free prog called ForScan. If you have multiple errors then the cluster is the issue. The program is good. The cost to fix the cluster is £80 revtonic fix it for that much. I had the cluster issue that made the alarm keep going off. Car shutting off while driving. Scary the first time it happen. But normally the cluster is the problem..

Share this post


Link to post
Share on other sites

Have you checked the passenger side fuse box. Make sure all the cables are attached. People tend to kick up there and wires become lose.

Share this post


Link to post
Share on other sites

I'll check the passenger fuse box over the weekend.

With regards to the ECU I've looked about and someone has said they had the jack the car to get to it? Is this correct?

I want to send it off to BBA, surely ECU removal is easier/simpler?

Share this post


Link to post
Share on other sites

Perfect!

Thanks Stoney!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now