AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


plinolrach

Turbo

3 posts in this topic

Having owned our c-max for just 5 weeks and following the car alarm going off all the time we now have a more serious problem, the Turbo has gone!! We purchased the car privately so have no come back on it. The car is an 2005 plate and has done 50,000 miles. We have had a quote for repairs for £900+ and have been told this is a common fault with the c-max and to prevent it happening again it should be serviced every 5,000 miles?? That would mean us servicing it about 3 times a year, we bought the car thinking it was going to be more economical to run that our old rover, has anyone got any advice on this as we are really gutted at the moment.

Share this post


Link to post
Share on other sites
 

Having owned our c-max for just 5 weeks and following the car alarm going off all the time we now have a more serious problem, the Turbo has gone!! We purchased the car privately so have no come back on it. The car is an 2005 plate and has done 50,000 miles. We have had a quote for repairs for £900+ and have been told this is a common fault with the c-max and to prevent it happening again it should be serviced every 5,000 miles?? That would mean us servicing it about 3 times a year, we bought the car thinking it was going to be more economical to run that our old rover, has anyone got any advice on this as we are really gutted at the moment.

Just to keep you informed, we had the turbo replaced(twice, the first one was faulty) and many other parts with it after getting a Technical Service bullitin regarding the problem!!! This cost us a total of £1075 and was to prevent the problem from happening again. Guess what we have had the car back 5 weeks today and the turbo has gone again!! We are now locked in a battle with our garage who have done the work and ford Furrows who they bought the parts off and have no car!! We would be really grateful to know if any of you have had Turbo problems??

Share this post


Link to post
Share on other sites

Hi mate, did they say why turbo failed? at a guess the oil supply pipe is or was blocked, cant think of any other eason for a turbo to fail so soon unless it'a not getting lubricated..

If it was then it should have been cleaned when first turbo blew.. hope you get sorted soon mate.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now