• Huge Range of Ford Parts
      Huge Range of Ford Parts
    • Share Your Car Experience
      Share Your Car Experience
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Join Premium & Save
      Join Premium & Save
    • Get Your Club gear
      Get Your Club gear

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.

Sign in to follow this  
Followers 0

Help. I Don't Know What to do...

1 post in this topic

Mondeo 2.0 Tdci Zetec S 53 Plate 71000 miles

I hope you can help me out here. About 6 weeks ago, I had a situation where my car wouldn't start and I had the flashing glow plug light, a situation that worryingly crops up frequently on forums. During the following week, the car would start OK but then would lose all power and stall while I was driving. As I travel through the Mersey Tunnels twice a day this was extremely stressful as I did not want to stall in the busy tunnel. I rode my luck a bit and had stalls just before and just after the tunnel.

Took the car for a diagnostics at a back street garage in Liverpool and they said the only error code showing was the Camshaft sensor. I replaced this and it has been absolutely fine for the last 6 weeks. Until last Friday that is. Driving to work, it repeatedly lost all power when trying to accelerate when joining the motorway and this must have happened about 8 times before I managed to limp home. This has repeated every day since, even when not accelerating hard. Only yesterday, coming out of the tunnel, in 3rd gear doing just under 30mph the engine again lost power and stopped. Luckily, I was 100yds out of the tunnel. As a consequence, my stress levels have increased again.

Another diagnostic test pointed to an Overboost in the turbo wastegate ? I'm no mechanic. I do have the Haynes manual which always makes things sound so easy, but in reality I know they are not. But what could cause an overboost. Does the EGR need a good clean out. Or could it be a faulty turbo.

What to do? Do I go to the main Ford dealer and risk paying through the nose for possibly unnecessary work. But I don't know any other garages who specialise in diagnosing and fixing the problem - there's nothing listed in the yellow pages. I could just end up throwing good money away trying to get it fixed, so should I trade in the car for something else ?

Any help or advice would be appreciated



Share this post

Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
Followers 0