Jump to content


Show
Photo

Ghia Badge question


  • Please log in to reply
4 replies to this topic

#1 tecstar

tecstar

    Newbie

  • New Member
  • Pip
  • 9 posts
  • Ford Model: Focus Ghia 2005 (55)
  • Location:

Posted 24 April 2009 - 11:05 AM

On the back of my Ghia, I have the "Ghia" badge , but not the "Focus" badge.
I'm wondering if its missing intentionally, or if it was lost/removed or whatever at some point. Are they usually stuck on, or should there be some holes?
Just wondered if anyone knows if Ford are in the habit of leaving off the "Focus" from any of their models.

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 dezwez

dezwez

    Dezwez

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 4,291 posts
  • Name: Derek
  • Ford Model: ford focus 1.8 zetec mk 2.5
  • Year: 2008
  • Location: Cambridgeshire

Posted 24 April 2009 - 05:42 PM

;) stuck on

#3 Whelk8891

Whelk8891

    Settling In Well

  • New Member
  • PipPipPip
  • 95 posts
  • Ford Model: Focus Mk1 Saloon 1.8 TDDi
  • Location:

Posted 24 April 2009 - 07:18 PM

I took the badges off mine. I figured if I do it carefully, that's a much less damaging option than some thieving little !Removed! removing them with a screwdriver.

#4 tecstar

tecstar

    Newbie

  • New Member
  • Pip
  • 9 posts
  • Ford Model: Focus Ghia 2005 (55)
  • Location:

Posted 26 April 2009 - 11:28 AM

As far as I can tell it should have the "Focus" on there, so i'm gonna try and get hold of a new badge.

#5 SierraYankee99

SierraYankee99

    Too much time on the boards

  • New Member
  • PipPipPipPip
  • 859 posts
  • Ford Model: Ford
  • Location:

Posted 26 April 2009 - 02:12 PM

Try Here


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users