Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


tigacatch

Revs Hunting 2000-2500

27 posts in this topic

What's really pee ' ing me of that all problem are to only a specific rev range. Just so weird.

Share this post


Link to post
Share on other sites
 

Well tried out new vacuum pipe today and that little white valve for the vacuum too but no luck. I did however notice that when I disconnect the vacuum hose the revs increase to about 2000 rpm and pressing the throttle would gradually increase the revs. The problem at 2100 rpm disappearing. Nice and smooth. However I can't drive it with the vacuum hose disconnected. Some kind of vacuum fault somewhere else. The map sensor works with vacuum too. Maybe that at fault? Disconnected it and started engine but problem still there ?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now