Jump to content


Photo

Engine Management Light After Footwell Fuse Box Fix

fuse passenger footwell engine management dashboard

  • Please log in to reply
1 reply to this topic

#1 dougie5832

dougie5832

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Name: gordon
  • Ford Model: Focus
  • Year: 2008
  • Location: Lanarkshire

Posted 27 January 2014 - 09:54 AM

Hi can anyone help?

 

Passenger footwell cable had come loose from fuse box. Have fixed it and all the things that were affected are now working...however the Engine Management Light is now solid and wont go off!

 

Is there anything i can do myself (not very mechanical mind) or is there anywhere CHEAP in the Motherwell/Hamilton Area i can get this reset ??

 

any help would be appreciated

 

Cheers

Gordon :)



Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 jeebowhite

jeebowhite

    Resident Loon

  • Super Mod
  • 17,724 posts
  • Name: James
  • Ford Model: Sea Grey Mondeo MKIV 1.8TDCi 140ps Zetec
  • Year: 2007
  • Location: Kent
Contributor

Posted 27 January 2014 - 12:02 PM

Two things you can do!

 

1) disconnect the battery for a half hour (make sure you have the radio code

2) have a look at my signature for "Got an error on your car?" and buy yourself a cheap code reader that could do this for you :)




Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have




Also tagged with one or more of these keywords: fuse, passenger, footwell, engine management, dashboard

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users