Jump to content


Photo

03 Ford Mondeo Cooling Fan

cooling fan

  • Please log in to reply
8 replies to this topic

#1 regsy

regsy

    Newbie

  • Members via FB
  • Pip
  • 5 posts
  • Name: ian
  • Ford Model: mondeo
  • Year: 2003
  • Location: Yorkshire

Posted 28 January 2014 - 08:47 AM

hi folks im new here so please be gentle lol i have a 03 ford mondeo 2ltr petrol i have only just bought the car and have noticed that as soon as i turn the key in ignition without even starting the engine the cooling fan comes on and stays on until i switch off the ignition anybody any ideas ???????



Have something to contribute?

Sign in or register to start a topic...

#2 jeebowhite

jeebowhite

    Ford Enthusiast

  • Super Mod
  • 11,038 posts
  • Name: James
  • Ford Model: Sea Grey Mondeo MKIV 1.8TDCi 140ps Zetec
  • Year: 2007
  • Location: Kent
Contributor

Posted 28 January 2014 - 11:10 AM

Sounds like the thermostat needs visiting. Could be that the thermostat is stuck and so the fans stay to compensate!



#3 Dan62

Dan62

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 353 posts
  • Ford Model: Fiesta
  • Location: London

Posted 28 January 2014 - 11:17 AM

hi folks im new here so please be gentle lol i have a 03 ford mondeo 2ltr petrol i have only just bought the car and have noticed that as soon as i turn the key in ignition without even starting the engine the cooling fan comes on and stays on until i switch off the ignition anybody any ideas ???????

An unpugged or open circuit coolant temperature sensor will cause this.

Is the temp gauge on the dash working ok ? 



#4 regsy

regsy

    Newbie

  • Members via FB
  • Pip
  • 5 posts
  • Name: ian
  • Ford Model: mondeo
  • Year: 2003
  • Location: Yorkshire

Posted 28 January 2014 - 11:19 AM

hi guys yea forgot to mention the temp never goes over half 



#5 regsy

regsy

    Newbie

  • Members via FB
  • Pip
  • 5 posts
  • Name: ian
  • Ford Model: mondeo
  • Year: 2003
  • Location: Yorkshire

Posted 28 January 2014 - 12:12 PM

also it wouldnt be thermostat surely it comes straight on when the ignition is first turned on with the engine cold and engine not even started ?????



#6 Dan62

Dan62

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 353 posts
  • Ford Model: Fiesta
  • Location: London

Posted 28 January 2014 - 12:33 PM

Would be a good idea to see if you have a fault code,

I would still suspect the coolant temp sensor, if you have a multimeter you could check it out.

The coolant temp sensor is the only one that appears linked to the cooling fans.

The wiring diagrams show another sensor "Electronic Thermostat" which could be the sensor for the dash temp, but because all sensors feed to the PCM its not possible to tell what its function is.



#7 regsy

regsy

    Newbie

  • Members via FB
  • Pip
  • 5 posts
  • Name: ian
  • Ford Model: mondeo
  • Year: 2003
  • Location: Yorkshire

Posted 28 January 2014 - 01:22 PM

ok thanks dan to have a fault code would my engine management light come on ??? i have been reading a lot about the resister in the fan failing and causing it to stay on 



#8 Dan62

Dan62

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 353 posts
  • Ford Model: Fiesta
  • Location: London

Posted 28 January 2014 - 01:49 PM

Good point re the EML, you would expect it to be on !

As for the resistor, it doesn't control when the fan comes on, just its running speed and would probably fail causing the fan not to run.

Relays K45 and K46 control the fan, possibly one of these has gone bad.



#9 regsy

regsy

    Newbie

  • Members via FB
  • Pip
  • 5 posts
  • Name: ian
  • Ford Model: mondeo
  • Year: 2003
  • Location: Yorkshire

Posted 28 January 2014 - 02:59 PM

thankyou dan will try that at some point 




Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users