Jump to content


Photo

Battery Went Completely Dead Whilst Driving, Now Headlights Dont Work!

Battery headlights fuses?

  • Please log in to reply
1 reply to this topic

#1 MarkG70

MarkG70

    Newbie

  • Members via FB
  • Pip
  • 3 posts
  • Name: Mark
  • Ford Model: Fiesta 1.4 Zetec
  • Year: 2011
  • Location: Lancashire

Posted 31 January 2014 - 06:23 PM

Hi

 

Driving to work this morning when everything on the car just cut out completely - dead

 

Got to side of road and turned ignition off an on again and car restarted and has so far managed to get me to the rest of way to work and back home again

 

Problem is that noticed on way home that I don't have any head lights - I have main beam and side lights but nothing else on either side

 

I'm hoping that this is just something as simple as a fuse blowing, and not something more sinister or expensive!

 

Any help appreciated

 

Cheers



Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 jeebowhite

jeebowhite

    Resident Loon

  • Super Mod
  • 17,104 posts
  • Name: James
  • Ford Model: Sea Grey Mondeo MKIV 1.8TDCi 140ps Zetec
  • Year: 2007
  • Location: Kent
Contributor

Posted 03 February 2014 - 01:21 PM

Could be that the alternator is having issues. I wonder if the bulbs both blew when the car died? perhaps a power spike caised the car to die and blew the bulbs?




Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have




Also tagged with one or more of these keywords: Battery, headlights, fuses?

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users