• Join Premium & Save
      Join Premium & Save
    • Share Your Car Experience
      Share Your Car Experience
    • Get Your Club gear
      Get Your Club gear
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • Huge Range of Ford Parts
      Huge Range of Ford Parts


MarkG70

Battery Went Completely Dead Whilst Driving, Now Headlights Dont Work!

2 posts in this topic

Hi

Driving to work this morning when everything on the car just cut out completely - dead

Got to side of road and turned ignition off an on again and car restarted and has so far managed to get me to the rest of way to work and back home again

Problem is that noticed on way home that I don't have any head lights - I have main beam and side lights but nothing else on either side

I'm hoping that this is just something as simple as a fuse blowing, and not something more sinister or expensive!

Any help appreciated

Cheers

Share this post


Link to post
Share on other sites
 

Could be that the alternator is having issues. I wonder if the bulbs both blew when the car died? perhaps a power spike caised the car to die and blew the bulbs?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now