Jump to content


Show
Photo

Fluid Leak


  • Please log in to reply
3 replies to this topic

#1 rutts

rutts

    Newbie

  • Budding Enthusiast
  • Pip
  • 2 posts
  • Name: Paul
  • Ford Model: galaxy
  • Year: 2007
  • Location: Essex

Posted 04 February 2014 - 09:33 AM

Hi All,

I have a leak on my 2007 galaxy. It's a 2.0 dohc engine. The leak is coming from the left hand side of the engine (as you look at it). I thought it was oil at first but having left a container under last night it appears to be a reddy brown fluid. It's leaking from around what appears to be the engine mount. Are these fluid filled or is the engine it's self leaking and transferring across? I've attached some pics. Thanks

Attached Thumbnails

  • 20140204_0857541.jpg
  • 20140204_0858191.jpg
  • 20140203_1820141.jpg
  • 20140203_1820001.jpg
  • 20140203_1819541.jpg


Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 scudney

scudney

    Settling In Well

  • Budding Enthusiast
  • PipPipPip
  • 51 posts
  • Ford Model: galaxy

Posted 04 February 2014 - 02:48 PM

could it be power steering fluid?



#3 martyntdci

martyntdci

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 1,492 posts
  • Name: martin
  • Ford Model: focus titanium x/comms/sports pack
  • Year: 2008
  • Location: Staffordshire

Posted 04 February 2014 - 07:36 PM

was just to state the obvious, as its straight under the resovoiur..........

 

notice its on the max line, did you fill it up noticing that it ws low? the only other thing it can be that high up is oil..... check it.....

 

my only other thing is antifreeze, but that look like oil to me..... 



#4 rutts

rutts

    Newbie

  • Budding Enthusiast
  • Pip
  • 2 posts
  • Name: Paul
  • Ford Model: galaxy
  • Year: 2007
  • Location: Essex

Posted 04 February 2014 - 07:59 PM

The only fluids I topped up where the water and oil. But, to be fair, I haven't touched em for a while. The other fluids were all as I found em. I thought the leak round the mounting looked like oil but the liquid I collected wasn't oil. That's why, although low, I discounted an oil leak.I'm gonna degrease it later this week and have another look and see what I can see.




Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users