AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


alexg

Lcd Display Only Shows Trip Computer And Settings - No Ford Audio Displayed

8 posts in this topic

Hi,

We just purchased a 2008 S-Max Titanium a week ago! This comes with a Sony DAB Radio CD, Bluetooth, USB and Aux audio input.

I understand we should be able to see and control phone, audio and iPod features from the LCD panel behind the steering wheel, but it only shows Trip Computer and Settings.

The other day my wife said it all the audio features displayed on this panel for a minute then disappeared. I have never seen them displayed. Does anyone know what is likely to be the reason for this?

One other thing I noticed, is that the Sony radio does not turn off when the car turns off, and also the Clock on the radio looses its time after turning off the car, even though we set it. Could this be related?

Otherwise we can control the iPod and Phone from the Sony radio itself, just not from the LCD panel behind the steering wheel

Share this post


Link to post
Share on other sites
 

did you buy it from a dealer or privately?

have you tried going through the menus on the convers screen?

does the stereo power off when you lock the door.

take a look here,to see if your car has any outstanding recalls etc.plus this will list everything that your car comes with.

https://www.etis.ford.com/home/welcome.do

you may have to go to the preferences and reset to english uk.

Share this post


Link to post
Share on other sites

Hi. Thanks for the quick reply!

We bought the car from Car Giant, and I am hoping they can help.

I tried all the menus and cannot find anything related to Ford audio. I don't think the radio turns off when you lock the door but will check. The display is already set to English.

This is some of the info from the Etis site:

Build Date: 29.09.2008

Vehicle Line: S-Max/Galaxy 2006-

Body Style: 5 Door SAV (S-MAX)

Version: Series 60

Engine: 2.3L Duratec-HE (160PS) - MI4

Transmission: 6-Speed Automatic Transaxle - AWF21

Drive: RHD FWD

Emission: Stage IV Emissions

Air Conditioning: Dual Zone Auto Temp Control A/C

Territory: (+)"GB"

Paint: Tango (Metallic)

Interior Fabric: Waffle B (A-C) / Midnight Black

With Trip Computer


Thatcham Catergory 1 Alarm System


Less Vehicle Tilt Sensing


With Rear Parking Aid


With Front Parking Aid


60 AH Battery


Less Auxiliary Compact Disc Player


With A/V Jack


BT/VC Phone Interface + USB Connect


Will Dual Band Type 2 Antenna


High Level CD+AM/FM+DAB


Ice Feature Pack 15


With 8 High Series Radio Speakers


Phone Kit - Hands Free IV - English


Less Family Entertainment System


Voice Activated Module - British

Share this post


Link to post
Share on other sites

well that puts you in a very good position then.because iirc you have 28 days to let the supplying dealer know of any/all faults and they by law have to rectify the problems.again iirc this does not mean they go to the warranty.

it may need updating of the ecu??? and that may mean a visit to 'fords'?

Share this post


Link to post
Share on other sites

What you describe suggests that the Sony radio has been refitted after an aftermarket unit has been in there. Somebody has probably messed with the wiring behind the radio to swap the permanent & switched live feeds over.

Share this post


Link to post
Share on other sites

Car Giant took a look and confirmed that the radio is faulty and they will be replacing it.

Interestingly on a long journey last night, all the audio feature popped up on the LCD display behind the steering wheel last night, but once that happened, the radio kept turning off and on again. Clearly there is something wrong!

Lets hope the replacement works!

Share this post


Link to post
Share on other sites

Ok after many weeks of back and forth, Car Giant replaced the radio. This did not solve the issue. They also replaced the battery as it went flat at one point (possibly unrelated).

They eventually sent it to Ford, who have apparently replaced the whole dashboard!

We then picked it up yesterday and I now see Phone, Radio, iPod features etc. on the dashboard! I also now have voice control which never worked before.

HOWEVER, the last time we turned on the car, we only saw Trip Computer and Settings once again. After turning off car and trying again, everything else showed again. Sometimes it works, other times not.

Looks like it is going back to Ford - has anyone else experienced this behaviour?

Share this post


Link to post
Share on other sites

I've had my 09 plate mondeo since 2011 and I also had another mk4 mondeo for a few months before that, both with the convers+ system and both have been glitchy at times showing only settings and tripmeter... On some occassions I foundpressing the voice button fixed things and other times it needed a stop and a restart or even an overnight rest before it fixed itself.... As of today however I have the same problem and its been stuck for 3 days..... I have in the past asked Ford to update the software.... they say they do but never seems to improve things.. I have been fortunate for this not to happen for 6+ months sometimes and sometimes it goes wrong on a weekly basis.... No I have no phone functionality or voice control.... I wonder if the bluetooth module has packed in or is causing it somehow....

Interested to know if you managed to resolve your issues.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now