• Get Your Club gear
      Get Your Club gear
    • Share Your Car Experience
      Share Your Car Experience
    • Savings Up to 15% Off For Members
      Savings Up to 15% Off For Members
    • 1000's Of Fords For Sale
      1000's Of Fords For Sale
    • Join Premium & Save
      Join Premium & Save
    • Huge Range of Ford Parts
      Huge Range of Ford Parts

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


big g1985

Strange Electrical Fault

4 posts in this topic

After my wife drove through a big puddle we e had a strange electrical fault when u lock the car (54 plate 1.6 tdc)

Basically when you lock the car the wipers will operate a small amount and the heater control lights illuminate then go out.

I've check the fuse box in the engine bay and I've noticed here is a loose live cable at the top of the box

Can't see where it should attach.

I've moved it out of he way I case it was shorting on something but I still have the same fault

Any help will be appreciated

Thanks

Share this post


Link to post
Share on other sites
 

Sounds like moisture in the box, check the engine bay for signs of water ingress.

Share this post


Link to post
Share on other sites

Turns out it was moisture in the cabin fuse box corroding the contacts supposibly a common fault

Share this post


Link to post
Share on other sites

Thought as much, sadly it is more common than would like to be!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now