Jump to content


Show
Photo
- - - - -

Fiesta Clutch Pedal Issue

loose disconnected clutch pedal floppy broken bent slipping

  • Please log in to reply
1 reply to this topic

#1 fiestanutter

fiestanutter

    Newbie

  • Budding Enthusiast
  • Pip
  • 2 posts
  • Name: adam
  • Ford Model: fiesta
  • Year: 2005
  • Location: West Midlands

Posted 27 February 2014 - 11:02 PM

Hey guys just wanted to share this with you all.

 

I have a Ford fiesta 2005 MK VI and recently my clutch pedal started to click, sometimes it would be fine and other times pedal went straight to floor.

So I had it recovered to my local garage, and was told it is a common problem and was told to buy a clip from Ford, cost less than 50p.

The garage fitted it for free as i'm a regular but guess what it didn't last 5 days, the clip failed.

Again recovered to garage when they checked this time the shaft or connecting rod for the master cylinder had slightly worn hence the clip had come off, honestly this clip looked like it was made from tin foil it was that thin, you could shave with it that's how thin it was.

I was then told that a hefty bill was expected as master cylinder and pedal assembly would have to be changed, I left to sulk and see if I can source parts myself thus reducing the bill, amazingly I found a seller on Ebay selling a clip, more like a locking ring that fits on the end of the shaft where the pedal attaches and bingo!!! it has only sorted the problem out for good, so far been on my car for around 5 weeks and still everything ok, im using the same clutch master cylinder and pedal and it cost less than £20 and best of all I fitted it myself in under 10 mins although it was a pain to get to.

 

Just thought id share this with you folks  I will send link here if it will allow me.

I tried pasting link guess it wont allow me, but if you type on the search bar in ebay "ford fiesta pedal clip" it will pop up

you get an allen key and washer and the ring.

 

 

 

I hope this helps you guys.



Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 Nathan_M

Nathan_M

    Too much time on the boards

  • Members via Twitter
  • PipPipPipPip
  • 717 posts
  • Name: Nathan
  • Ford Model: Fiesta Flame Mk6
  • Year: 2004
  • Location: Cornwall

Posted 28 February 2014 - 01:04 AM

This seems to be a terrible design fault in the fiestas amongst others like the washer jets which try to drown the engine, mine seems okay and has so far in its 10 years survived without this fault I looked down there and it seems fine on mine doesn't look like it even wants to cause trouble, hopefully it won't ever go on mine at least while I have it.

Sent from my GT-N5110 using Ford OC mobile app


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have




Also tagged with one or more of these keywords: loose, disconnected, clutch, pedal, floppy, broken, bent, slipping

0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users