Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Sign in to follow this  
Followers 0
wayne

MK3 2001 MONDEO ENG MAN LIGHT

2 posts in this topic

around 5 weeks ago my engine management light came on whilst driving the still drove perfectly got home took battery off for 30 mins connected it back up the light as stayed off untill today when its come on again whilst driving i took battery off again drove the car too work and back and to the supermarket and its fine the lights stayed off...whats causing it to come on like i say its 5 weeks since it last happend but the car drives perfect ..what i have noticed is its using more fuel could it be the lambda sensor but theres two sensors one on the down pipe which looks difficult to remove and one just after the cat which looks easier????..is this my problem??

Share this post


Link to post
Share on other sites
 

the only way to check is to read the codes when the light is illuminated. as it could be any one of the sensors playing up.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
Sign in to follow this  
Followers 0