Ford Owners Club - Ford Forums Messages

Club Announcements

Ford Fair 2016: Tickets and stand passes are now available to purchase. More info here.

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

AdBlock Warning

Parts of this website do not function properly with AdBlock enabled on your device. To get the best user experience on our website, please disable Adblock for this website (domain) on your browser.


Markno1

Urgent Help Required Please!

5 posts in this topic

Hi all...

Im new to the forum and having a problem with my 2.0tdci 140 59plate. The problem only happens when towing a trailer/caravan but seems to drive fine the rest of the time. The problem I the car judders or hunts quite violently through most of the rev range in most gears. There are no warning lights too. Regards Mark.

Share this post


Link to post
Share on other sites
 

have you done an onboard diagnostic check?to see if there is any error codes logged.

take a look on 'ford etis' to see if your car has missed any recalls.

i do believe there may well be an update on the ecu to make your car run better.

you may have to ring fords and ask.

Share this post


Link to post
Share on other sites

Thanks for the reply. I haven't done a diagnostic check as yet and there are no updates showing on etis (well that its showing me anyway)

Share this post


Link to post
Share on other sites

Just a thought would a worn out dual mass flywheel cause the issue Im having by any chance. The cars done 77k and never had a clutch as far as im aware.

Share this post


Link to post
Share on other sites

did you get anywhere with this, I've got similar issues.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now