Jump to content


Show
Photo

Help Needed St200 2.5 V6 Estate


  • Please log in to reply
13 replies to this topic

#1 ove

ove

    Member

  • Budding Enthusiast
  • PipPip
  • 20 posts
  • Location:

Posted 06 March 2014 - 02:56 PM

I bought last week an st200 estate. Am having a bit of a worry about the head gasket after reading a lot of posts on this forum. Hope I haven't bought a bad un. Am finding that my coolant level is going down. Also checked back at the old mots that were given to me when I bought this car. The last mot mentions nothing about an oil leak. But the two mots before that says on the advisory's that there's an oil leak don't know why I hadn't noticed that. There is no cloudiness in the oil and can't smell exhaust fumes in the coolant. There's no ticking in the engine and the car drives really well. Am going to try and get the car on a ramp this weekend and look to see if any leaks. I'm not a mechanic please any advise would be welcome


Sent from my iPhone using Ford OC

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 btmaldon

btmaldon

    Ford Enthusiast

  • FOC Supporters
  • 2,476 posts
  • Name: Bruce
  • Ford Model: BMW 320i Coupe M Sport
  • Year: 2008
  • Location: Essex

Posted 06 March 2014 - 04:53 PM

The oil leak may just have been an oil pressure switch or something that has since been replaced. The coolant may be evaporating if the expansion tank cap isn't fully holding the pressure. It may be worth changing it.

 

Have you taken off the oil filler cap to see if there is a beige residue?



#3 ove

ove

    Member

  • Budding Enthusiast
  • PipPip
  • 20 posts
  • Location:

Posted 06 March 2014 - 06:56 PM

There's nothing in there the oils clean. It's gone into the garage as to pressurise the system. Should know bad or good by tomorrow. Would be a shame if there's a major problem as it is a lovely car. ImageUploadedByFord OC1394131581.051681.jpg


Sent from my iPhone using Ford OC

#4 ove

ove

    Member

  • Budding Enthusiast
  • PipPip
  • 20 posts
  • Location:

Posted 06 March 2014 - 06:57 PM

Why is it not letting me put pics up from my phone ?


Sent from my iPhone using Ford OC

#5 The Admiral

The Admiral

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 301 posts
  • Name: Vincent
  • Ford Model: Mondeo 2.0 Titanium X
  • Year: 2010
  • Location: Lancashire

Posted 06 March 2014 - 10:04 PM

That's a gorgeous motor the mk2 Mondeo ST200 was a great car and very rare these days especially in the estate model !, I had 2 x mk2 Mondeo 2.5 Ghia X auto & manual gorgeous and smooth power train, good luck hope its ok

Sent from my HTC One X using Ford OC mobile app

#6 ove

ove

    Member

  • Budding Enthusiast
  • PipPip
  • 20 posts
  • Location:

Posted 06 March 2014 - 10:39 PM

ImageUploadedByFord OC1394144952.175502.jpg


Sent from my iPhone using Ford OC

#7 ove

ove

    Member

  • Budding Enthusiast
  • PipPip
  • 20 posts
  • Location:

Posted 06 March 2014 - 10:41 PM

ImageUploadedByFord OC1394145055.614089.jpg


Sent from my iPhone using Ford OC

#8 ove

ove

    Member

  • Budding Enthusiast
  • PipPip
  • 20 posts
  • Location:

Posted 07 March 2014 - 07:19 PM

Just got car back from garage. There's a leak in the radiator. £60 plus vat and fitting. Def better than head gasket. Now I'm a happy man. Car can now go in Monday to have the key scratches taken out. Basically more than half the car is having a respray. Very excited to having it looking mint.


Sent from my iPhone using Ford OC

#9 ove

ove

    Member

  • Budding Enthusiast
  • PipPip
  • 20 posts
  • Location:

Posted 07 March 2014 - 08:07 PM

think i have finally figured how to put pics up on here here we go

Attached Thumbnails

  • IMG_3350.PNG
  • IMG_3375.JPG
  • IMG_3374.JPG
  • IMG_3356.PNG
  • IMG_3339.PNG


#10 The Admiral

The Admiral

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 301 posts
  • Name: Vincent
  • Ford Model: Mondeo 2.0 Titanium X
  • Year: 2010
  • Location: Lancashire

Posted 07 March 2014 - 08:32 PM

What's the mileage?, if you live in / near Manchester there's a great car body repair place called R&K motor bodies( near man city ) they can match any metallic colour perfectly! and a great price!, They did my wife's previous car '06 Focus Ghia in tonic front wing after a colleague caught it at work.

Sent from my HTC One X using Ford OC mobile app

#11 ove

ove

    Member

  • Budding Enthusiast
  • PipPip
  • 20 posts
  • Location:

Posted 07 March 2014 - 08:45 PM

the mileage is 88 thousand. I had booked the paint work to be done. when i bought it. a family friend is going to do it.. but obviously i wasn't going to have it done if the head gasket had gone. i bought the car for £1000. so hopefully a good purchase.



#12 ove

ove

    Member

  • Budding Enthusiast
  • PipPip
  • 20 posts
  • Location:

Posted 10 March 2014 - 09:40 PM

I want to change my stereo head unit from factory and I would like to put a 2 din one in. I know that the hole is about 1.5 din. What would best the best way to fit one in.


Sent from my iPhone using Ford OC

#13 The Admiral

The Admiral

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 301 posts
  • Name: Vincent
  • Ford Model: Mondeo 2.0 Titanium X
  • Year: 2010
  • Location: Lancashire

Posted 10 March 2014 - 10:16 PM

Haven't you got the 6 disc CD interchanger under the passenger seat?

Sent from my HTC One X using Ford OC mobile app

#14 ove

ove

    Member

  • Budding Enthusiast
  • PipPip
  • 20 posts
  • Location:

Posted 14 March 2014 - 05:06 PM

Yeah but I would like a touch screen with integrated Bluetooth, reversing camera and GPRS.


Sent from my iPhone using Ford OC

Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users