Ford Owners Club - Ford Forums Messages

Club Announcements

Discounted Car Insurance: Owners Club insurance could save you money on your car insurance. Get a quote

Review your Ford: Help others when it comes to buying a car like yours and review your Ford now

Ford Car Parts: View All ford car parts by category. Look for Ford Car Parts now!


luk

blown turbo on ford focus TDCI 2003? 115ps 90,000

10 posts in this topic

Hi everyone,

my turbo blew on the motorway and as i pulled up the engine reved at full till i stalled it to stop it.

Iv had a new turbo fitted but there is still a major problem

The garage says it could be a bent valve or con rod due to the oil been forced in engine, but they need to investigate.

The car drives but wen pressing accellerator the engine vibrates and is slowish to pik up, but when u just hold pedal steady doing 2000 to 3000 revs the car feels fine and cruises along, its just when you press the pedal. It surges and struggles

The garage cleaned the intercooler, inlet manifold twice.

The car starts fine and idle`s ok ish, maybe a little iratic, and revs ok with no noises from engine.There are also no warning lights/codes

When the car get warm u get a few drops of oil coming out of exhaust and a bit of smoke off this, so there is still oil in sytem.

My next plan is to remove intercooler and try and drain oil a bit more if theres any in.Iv also added some fuel system treetment.

ALSO iv removed the EGR valve , iv been told i need to clean this ? how do i do this ? is it the halam key socket on the valve ?

ANY IDEAS on what it could be, and does anybody think it could be the valve / conrod ? when it is fine when idleing

What would be the best way to clean the intercooler ?

Thanks in advance for reading

Share this post


Link to post
Share on other sites
 

Hi everyone,

my turbo blew on the motorway and as i pulled up the engine reved at full till i stalled it to stop it.

Iv had a new turbo fitted but there is still a major problem

The garage says it could be a bent valve or con rod due to the oil been forced in engine, but they need to investigate.

The car drives but wen pressing accellerator the engine vibrates and is slowish to pik up, but when u just hold pedal steady doing 2000 to 3000 revs the car feels fine and cruises along, its just when you press the pedal. It surges and struggles

The garage cleaned the intercooler, inlet manifold twice.

The car starts fine and idle`s ok ish, maybe a little iratic, and revs ok with no noises from engine.There are also no warning lights/codes

When the car get warm u get a few drops of oil coming out of exhaust and a bit of smoke off this, so there is still oil in sytem.

My next plan is to remove intercooler and try and drain oil a bit more if theres any in.Iv also added some fuel system treetment.

ALSO iv removed the EGR valve , iv been told i need to clean this ? how do i do this ? is it the halam key socket on the valve ?

ANY IDEAS on what it could be, and does anybody think it could be the valve / conrod ? when it is fine when idleing

What would be the best way to clean the intercooler ?

Thanks in advance for reading

sounds like your system still have a fair amount of oil in it. You will need to clean all the pipework connecting the intercooler etc. Also give the egr valve a clean as its probably contaminated aswell.

not sure on what you could use to clean the parts, carb cleaner is good for egr valves though.

Share this post


Link to post
Share on other sites

Hi mate,

should think when your turbo blew it will have lost oil into the exhaust which may have contaminated your cat which explains why your getting oil droplets from tailpipe..

steve

Share this post


Link to post
Share on other sites
Hi mate,

should think when your turbo blew it will have lost oil into the exhaust which may have contaminated your cat which explains why your getting oil droplets from tailpipe..

steve

yes mate, lost about 1 to 2 litres out of exhaust when it happened , but ithought they didnt have a CAT diesles ?

Share this post


Link to post
Share on other sites

yep they have a cat but you can remove it as it isn't needed for the m.o.t... :)

steve

Share this post


Link to post
Share on other sites

yep they have a cat but you can remove it as it isn't needed for the m.o.t... :)

steve

oh right , thanks mate,

will it eventually burn out or will i need to remove / replace ?

thanks for replys

Share this post


Link to post
Share on other sites
oh right , thanks mate,

will it eventually burn out or will i need to remove / replace ?

thanks for replys

it will eventually burn off, all be it very smokey probably but it might clog the cat

Share this post


Link to post
Share on other sites

be easier to just decat it mate, shouldn't cost much to do either

steve

Share this post


Link to post
Share on other sites

just be gentle, and the oil should burn off in due course. after some time it might be a good idea to clean the pipework

Share this post


Link to post
Share on other sites

thanks jasmeet,

yes iv cleaned inlet and outlet pipe and intercooler has been washed out (they were dripping in oil)

iv done about 60 miles since, not sure if geting better or not

it seems to struggle at 2000rpm , very juddery , sometimes shaking the car

nobody seems to know the symptoms of a bent conrod or bent valve (thats what garage said it could be)

it idles over ok and is notbad upto 2000 rpm and over 2400 rpm

one day it stalled, then when i started it , i got tons of smoke out of exh so i parked up for the night and iv not had any smoke like that since

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now