Jump to content


Photo

Hello


  • Please log in to reply
4 replies to this topic

#1 Blackmagic

Blackmagic

    Newbie

  • Budding Enthusiast
  • Pip
  • 5 posts
  • Name: Carl
  • Ford Model: Mk3 2.2 tdci Estate
  • Year: 2006
  • Location: Sussex

Posted 25 March 2014 - 02:13 PM

Hi all,

 

Trust you are all well?

 

Names Carl, 28 and from Handcross, West Sussex.

 

Drive a 06 mk3 mondeo 2.2 tdci estate and a Honda CRZ. I have mainly joined because of a problem i am having with a car which ill describe in a new thread.

 

Hope someone can steer me in the right direction with this issue.

 

Thanks,

 

Carl



Have something to contribute?

Sign in or register to start a topic...



Sign up to FOC Premium Membership To Remove These Ads

#2 dezwez

dezwez

    Dezwez

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 5,080 posts
  • Name: Derek
  • Ford Model: ford focus 1.8 zetec mk 2.5
  • Year: 2008
  • Location: Cambridgeshire

Posted 25 March 2014 - 02:15 PM

Hi welcome :)

#3 xdazx

xdazx

    Newbie

  • Budding Enthusiast
  • PipPipPipPip
  • 293 posts
  • Name: Darrell
  • Ford Model: Mondeo
  • Year: 2008
  • Location: Leicestershire

Posted 26 March 2014 - 06:40 AM

Welcome whats up with car

#4 Blackmagic

Blackmagic

    Newbie

  • Budding Enthusiast
  • Pip
  • 5 posts
  • Name: Carl
  • Ford Model: Mk3 2.2 tdci Estate
  • Year: 2006
  • Location: Sussex

Posted 26 March 2014 - 07:23 AM

It all started when we had the floods recently. i drove through a puddle and the coil light started flashing and the car was then in limp mode.

 

Got home, switched it off and switched it back on and the car was back to normal.

 

It was a fairly intermittent fault but now its starting to happen on a daily basis.

 

The only patterns i am noticing is.

 

When under power pulling up a hill it goes into limp mode. (not all the time)

 

Also,

 

I can tell when it will go into limp mode because the fuel gauge will be showing a rapid fuel loss.

 

For instance: it will say 100 miles remaining then with in a few miles it will say 25 miles remaining. Then the coil light will start flashing, into limp mode. switch car off and on, then ill have 100+ miles in the tank.

 

Also,if the car has gone into limp mode alot during one day i find the engine management light comes on.

 



#5 xdazx

xdazx

    Newbie

  • Budding Enthusiast
  • PipPipPipPip
  • 293 posts
  • Name: Darrell
  • Ford Model: Mondeo
  • Year: 2008
  • Location: Leicestershire

Posted 26 March 2014 - 07:42 AM

My friends just had the same problem they ended up sending car back to finance ppl as was going to cost thousands to repiaire mind you theres was a jag with mondy engine.
You may have a leaking injector and few other things wrong. Ive just looked in my emails to try and find what they said was wrong with theres but i must of deleted it


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users