Jump to content


Show
Photo

miss fire tdci


  • Please log in to reply
2 replies to this topic

#1 misterford

misterford

    Newbie

  • New Member
  • Pip
  • 1 posts
  • Ford Model: mondeo tdci
  • Location:

Posted 14 May 2009 - 10:07 PM

hi guys i have a problem with my mondeo tdci 2002 with 95k on the clock, the glow plug light flashes all the time and from cold it smokes for a short while but when its warm its clear but still ticks over with a missfire and it dosent seam to pull as it used to i have cleaned the egr valve and the air flow meter but it,s still the same very lumpy on tick over any one got any idea,s as its driving me mad.

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 mintalkin

mintalkin

    Ford Enthusiast

  • True Ford Enthusiast
  • PipPipPipPipPip
  • 3,478 posts
  • Name: mintalkin
  • Ford Model: mondeo tdci 130
  • Year: 2006
  • Location: Staffordshire

Posted 15 May 2009 - 02:29 PM

you need to get the fault codes read from the ecu to see why the light is flashing, as it could be a number of things.

#3 rossi1947

rossi1947

    Newbie

  • New Member
  • Pip
  • 4 posts
  • Ford Model: ford mondeo tdci
  • Location:

Posted 03 September 2009 - 04:47 PM

you need to get the fault codes read from the ecu to see why the light is flashing, as it could be a number of things.



How did you get on with this? mine is doing same thing thought it was injectors but doesnt seem to have solved it?


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users