Jump to content


Photo

Mk4 Mondeo Reversing Camera


  • Please log in to reply
9 replies to this topic

#1 csaxton

csaxton

    Member

  • Budding Enthusiast
  • PipPip
  • 16 posts
  • Name: Craig
  • Ford Model: Mondeo Titanium X Sport 2.2
  • Year: 2011
  • Location: Kent

Posted 01 April 2014 - 06:51 PM

Hi All

I have a Mk4 2.2 titanium x sport and have a factory fitted reversing camera fitted.

Today, for some bizarre reason, when I put the car in reverse, it flickered for a second then turned off! The next time I engaged reversed, the camera did not even attempt to show. The sensors still work but I'm getting nothing on the display?!

Does anyone have an idea what the problem might be?

Cheers

Craig


Sent from my iPhone using Ford OC

Have something to contribute?

Sign in or register to start a topic...

Sign up to FOC Premium Membership To Remove These Ads

#2 btmaldon

btmaldon

    Ford Enthusiast

  • FOC Supporters
  • 2,552 posts
  • Name: Bruce
  • Ford Model: BMW 320i Coupe M Sport
  • Year: 2008
  • Location: Essex

Posted 01 April 2014 - 08:38 PM

If it is powered by the power to the reverse light bulbs, check the reverse lights are working first. If they are it must be the power to the camera or the earth.

 

After market cameras are wired as above, however I don't know if the factory fitted options are tied into the loom somewhere else.



#3 csaxton

csaxton

    Member

  • Budding Enthusiast
  • PipPip
  • 16 posts
  • Name: Craig
  • Ford Model: Mondeo Titanium X Sport 2.2
  • Year: 2011
  • Location: Kent

Posted 02 April 2014 - 08:09 PM

Thanks, I have checked the bulbs and all is good on that front.

I'm leaning towards a loose connection somewhere as when input it into reverse a couple of times today, it flickered on and off what the gear is engaged!

I'm reluctant to take it into Ford but it may be the only way!

Cheers


Sent from my iPhone using Ford OC

#4 csaxton

csaxton

    Member

  • Budding Enthusiast
  • PipPip
  • 16 posts
  • Name: Craig
  • Ford Model: Mondeo Titanium X Sport 2.2
  • Year: 2011
  • Location: Kent

Posted 01 May 2014 - 10:03 PM

Quick update on the camera...

I took it into Ford in Bromley, they had it for three days and finally replaced the camera, carried out a software update and gave it a clean for me all under warranty!

I also got to abuse a fiesta st as all other courtesy cars were out!!! Not a bad little car but too small for me.


Sent from my iPhone using Ford OC

#5 jeebowhite

jeebowhite

    Resident Loon

  • Super Mod
  • 17,749 posts
  • Name: James
  • Ford Model: Sea Grey Mondeo MKIV 1.8TDCi 140ps Zetec
  • Year: 2007
  • Location: Kent
Contributor

Posted 02 May 2014 - 10:24 AM

Glad to see you got it resolved!



#6 The Admiral

The Admiral

    Feet Under The Table

  • Budding Enthusiast
  • PipPipPipPip
  • 326 posts
  • Name: Vincent
  • Ford Model: Mondeo 2.0 Titanium X
  • Year: 2010
  • Location: Lancashire

Posted 02 May 2014 - 09:51 PM

Hi Craig, I've got sensors on mine but no camera, Would you Recomemed them? Or do u rely on sensors instead?

Sent from my HTC One X using Ford OC mobile app

#7 csaxton

csaxton

    Member

  • Budding Enthusiast
  • PipPip
  • 16 posts
  • Name: Craig
  • Ford Model: Mondeo Titanium X Sport 2.2
  • Year: 2011
  • Location: Kent

Posted 03 May 2014 - 11:25 AM

I try not to rely on them too much as it is otherwise you will become lazy!!!

To be honest, I wouldn't go out of my way to get one retro fitted, it was just a bonus that it came with all the other toys!

I would be equally as happy with just sensors.

Cheers


Sent from my iPhone using Ford OC

#8 jeebowhite

jeebowhite

    Resident Loon

  • Super Mod
  • 17,749 posts
  • Name: James
  • Ford Model: Sea Grey Mondeo MKIV 1.8TDCi 140ps Zetec
  • Year: 2007
  • Location: Kent
Contributor

Posted 07 May 2014 - 09:58 AM

Im going through the process now of ordering a camera and getting it installed, seems a fairly simple process and I will use it in conjunction with sensors. The mondeo rear window is not ideal for seeing small things like children, so I find I will use it all in conjunction with one and other and get the best peripheral vision.



#9 csaxton

csaxton

    Member

  • Budding Enthusiast
  • PipPip
  • 16 posts
  • Name: Craig
  • Ford Model: Mondeo Titanium X Sport 2.2
  • Year: 2011
  • Location: Kent

Posted 12 May 2014 - 09:03 PM

Keep us up to date mate


Sent from my iPhone using Ford OC

#10 jeebowhite

jeebowhite

    Resident Loon

  • Super Mod
  • 17,749 posts
  • Name: James
  • Ford Model: Sea Grey Mondeo MKIV 1.8TDCi 140ps Zetec
  • Year: 2007
  • Location: Kent
Contributor

Posted 13 May 2014 - 12:38 PM

Will do, I might need to start my own project thread!

 

Build thread :

 

http://www.fordowner...o-build-thread/



Have something to contribute?

Sign in or register to start a topic...


Not what you're looking for?

Register now, we have a huge community of enthusiasts to answer any questions you might have



0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users